mini2440 NOR flash menu problem

Hi, i am using mini2440 on linux with serial console  and when i boot from
NOR flash. I get the menu .
##### FriendlyARM BIOS 2.0 for 2440 #####
[x] format NAND FLASH for Linux
[v] Download vivi
[k] Download linux kernel
[y] Download root_yaffs image
[a] Absolute User Application
[n] Download Nboot for WinCE
[l] Download WinCE boot-logo
[w] Download WinCE NK.bin
[d] Download & Run
[z] Download zImage into RAM
[g] Boot linux from RAM
[f] Format the nand flash
[b] Boot the system
[s] Set the boot parameters
[u] Backup NAND Flash to HOST through USB(upload)
[r] Restore NAND Flash from HOST through USB
[q] Goto shell of vivi
[i] Version: 0945-2K
Enter your selection: s

 But when i press any option from menu, it doesnt show any output on serial
terminal. It just waits there. and so i cant download my own  customize
linux , cant change boot parameter etc.. 

Any help would be great. 


Problem Solved , Need to set Terminal Setting to ANSI in minicom

Also Disable Hardware Flow Control.

surendra patel
hello, i am using friendlyarm mini2440 w35. when i connected the board with
pc through dnw, the BIOS menu is not appearing in dnw and i have tried it
many times by restarting the board and i have also checked cable
connections(serial and usb) both are functioning but i m getting the same
problem again. please suggest me the solution.
thank you

Did it ever work for you?

Be aware of the RS232 cable connection type.  

You may have to JTAGtheNOR.pdf or JTAGingtheNOR.pdf (that's the article on
getting SuperVivi back into NOR) you will find.

Good luck.


Check to ensure that the boot switch is in the NOR flash boot mode. The
bootloader output appears in the NOR boot mode only.


shruti verma
I think there is some problem with NAND/NOR flash memories in my board,it
was working fine but the next i switched it on,the screen appears blank.
even in hyper terminal its showing some weird characters.
Please help...

While booting from NOR, it does not enter into the boot menu. It get stuck
in USB loop. Asking for SD card.
 What is the way to access the card from Ubuntu?

Sandeep Sondagar
Dear Meher,

It is not getting stuck. It has booted successfully in NOR.

Newer board has supperboot bootloader.
Above posted menus were available in SuperVivi.

Search for "JTAGing the NOR" to burn SuperVivi on Mini2440 or use superboot

Sandeep Sondagar

Thank you Sandeep. I will see the superboot guide.

Dheeraj Saxena
Im facing problem in porting uboot to nand:

# ./s3c2410_boot_usb ../u-boot.bin 
Unable to claim usb interface 1 of device: could not claim interface 0:
Device or resource busy

with sudo error comes:
sudo s3c2410_boot_usb ../u-boot.bin 
sudo: s3c2410_boot_usb: command not found

I added path of tool.
Any solution?


Ayyappan Mk
Hi Dheeraj,

Check whether s3c2410_boot_usb has executable permissions and also it's
location should be in any of the Linux compatible file systems formatted
drive(in case u have multiple OS installed).

Both are must. Good Luck!