NOR flashing problem

Marco
Hi,

I downloaded the supervivi-128 e uboot-128 for my mini2440 256MB. I tried
to flash the nor memory with supervivi-128 using the guide in the Downloads
section but when I turned on the board with the S2 in nor position the
hyperterminal said "NAND NOT SUPPORTED". I tried than to flash the nor with
uboot-128 loader, alwais following exactly the guide, but nothing happened.
 Now I'd like to return to the first loader but I can't flash the nor
because H-JTAG program says "can't programm the destination address". I
didn't change the settings during the two flashing...

What should I do now??? Please help me I don't now what to do.

Regards,
Marco.

Gautam
Hi Marco,

You need to disable the target MMU when flashing the NOR. The most likely
problem is with the Init Script settings. Here is a possible solution:

1. Start H-Jtag and launch H-Flasher utility.
2. Choose the correct NOR part in step 1 - Flash Selection. (SST-39VF1601
in my case. Check yours.)
3. In step 2, enter correct addresses (Flash = 0x00000000 and RAM=
0x30000000)
4. In step 3, ensure that correct init script file (*.hfc from your
FriendlyARM DVD) is selected.
5. In the same step, use the arrow buttons on the right to add a Flash
command (Left arrow). Enter the command by double-clicking the "Cmd"
column. Choose "Disable MMU" command. Move this command to the top of the
script command list using the Up arrow.
6. Now proceed to step 4 and Flash your NOR as usual.

That should do it.

Good luck!

Gautam

Marco
Hi,

It warks!!!Thanks a lot Gautman

Marco

yuensli
I'm sorry..i also have this problem now..

And I have tried the solution as mentioned by Gautam

but I can't find the cmd function "Disable MMU" in step 5.

Can you tell me where this function is ??

I'm using H-JTAG V1.0 Release ...


Thank you very much~

Gautam
Hi yuensli!

You need to use H-Jtag v0.4.4. You can download it from here:

http://www.friendlyarm.net/downloads

Then follow the steps mentioned earlier.

Good luck!

Gautam

Dodi Suwardi
hi Gautam
please help me...same problem here...
I having programming the SST39VF1601 , erasing and blank the chip, but then
i lost my electricity and computer shut-down instantly, apter power
recovery i found the mini2440  hang cannot reset , lcd screen full blank
with white colour, pressing reset not respond , when i try to program i see
"flash error" on H-flash software: i think the the SST39VF1601 cannot be
detect when i press reset and check facility in H-Flash software

"Can't download driver to specified address ...!!!"

what should i do..??  please help me...

Mark
Hi,

I had a different problem when trying to reprogram FLASH worked first
couple of times then gave a 0x120B0000 error. Seems the MMU is a pain in
the ****, I am trying to load and run another Bootloader/ROM monitor
RedBoot. This runs when I load it into RAM from supervivi but does nothing
when I load it into ROM and reboot, probably also caused by me not
configuring the MMU properly though there is code in RedBoot to do this.
However at least I am back to a working system, wonder why the DisMMU
command wasn't in the script to begin with.

Thanks again for that thought I would have to figure out how to do this
manually.

Gautam
Hi Dodi,

The H-Flash software ha a button to detect the NOR flash device. Make sure
that the .hfc and .his files are loaded in H-Jtag before proceeding. Also
ensure that the "Disable MMU" (DisMMU) command is added to the top of the
script. Then click on the button to check the NOR flash chip.

Sorry for the delay in replying as I was busy with my day job! ;(

HTH!

Regards,

Gautam

Fatih KESER
dear friends,

we have a S3C2440 development board named SDK2440v2. we have also a NOR
programming problem just as you share here. Most probably :) I understood
the solution but I don't have the files you mentioned above as *.hfc and
*.his files. can anyone send these files to my e mail? fatihkeser@yahoo.com
256M nand 2M nor

thanks for assist...

mohamad
Hi All

I have same problem on mini2440 board J-tag.I did all upper steps
exactly.but the H-Jtag program detect my board and the flasher program can
not detect my board yet! and issue this error message consecutively : can't
halt target and make it enter debug state.
also I did mr.Gautam commands step by step exactly. but that message issue
again! and I can not flash my nor

Gautam
Hi mohamad,

>>>>>>>>>>>>>
.but the H-Jtag program detect my board and the flasher program can
not detect my board yet! 
>>>>>>>>>>>>>

When you connect your JTAG cable to the mini2440 board, does it show the
Processor ID correctly in blue letters in the H-JTAG software? If it shows
0x00000000 or 0xFFFFFFFF in red colour, it means that the board is not
detected correctly.

This is most likely caused by incorrect parallel port pin settings in the
H-JTAG software. For correct settings, refer to the Mini2440 User Manual or
the document called "Jtagging the NOR". Both these are available in the
Download section on the FriandlyARM web site.

HTH!

Gautam

Vishad
I have the same issue described here. I tried to follow the step and it
comminicate ok with H-JTAG but as soon as i try to program it, i have
error: "can't halt target and make it enter DEBUG state". I used H-JTAG
v0.4.4 and v2.1 with same results. 

Other question i have is about TAP Configuration in H-JTAG. What to set and
where to get those settings? 

Any guidance is appreciated.

Gautam
Hi Vishad,

Sorry for the late reply.

1. You need to ensure that the .hfc script file is correct for your Flash
part number. Different lots of the board ship with different part numbers
for NOR and NAND Flash. So, unfortunately there's no guarantee which one
will be present on yours. Your best bet is to write down the **exact** NOR
no. on a piece of paper. (Look on the FA Downloads page for example part
numbers) Then you can google for a .hfc file with the same name as your
part number and you should likely find it.


2. Download the PDF:
http://www.andahammer.com/assets/Uploads/All2440/Firmware/JTAGingTheNOR.pdf

It contains the settings you need on page 2. :)

HTH,

Gautam

srinivasa rao
Mr. Gautam, great job.

your step by step procedure working perfectly.

miniarm
Hello Gautam,

I have done exactly the same steps as discussed here as well as in pdf
file, but I am still getting this erorr. I have also downloaded H-Jtag
version 0.4.4. 

can't halt target and make it enter DEBUG state"

Can you please tell me what could be wrong over there? Also I have tried
download .his and .hfc file to the board and also disable MMU, still I am
not able to get the board running well.

I have followed exactly same steps. Look forward to hear from you soon.

can you please share info about how to detect NOR chip?

Gautam
@mniarm,

Please check if your boot switch is in NOR position.

Regards,

Gautam

miniarm
@Gautam,

I am operating borad in NOR position only. I don't know what is wrong.

Gautam
@miniarm:

Are you sure you loaded the correct .hfc and .his files for your NOR Flash
part number?

Do a double check after loading the .his file and see if the script
commands are loaded in the right hand side view of H-Flasher. Make sure
that the DisMMU command (Disable MMU) is the first one in the list. If the
target still does not halt, insert a Delay command with a delay value of
100 or 150 ms. and try again.

Good luck!

Gautam

miniarm
@Gautam,

Thanks for the reply. I will try your solution and let you know the status.

miniarm
@Gautam, @davef,

Can you please help me out on this link.
http://www.friendlyarm.net/forum/topic/4824

support driver
The bootloader that comes factory installed on the Micro2440 and the
Mini2440 board is called Supervivi. I don't personally like it. It has very
limited support and requires a YAFFS filesystem for the root filesystem. So
when I bought my board I began to immediately search out an alternative.
The bootloader by choice, it seems, is a modified version of U-Boot with
modifications for the Mini2440 board's hardware

http://www.downloaddriver.ga driver and software download 
http://www.printer-driver.ga printer driver download
http://www.eprinterdriver.ga epson printer driver
http://www.drivers-hp.net/ HP Printer Driver Download 
http://aboutdrivers.blogdetik.com/ Hp Printer Review
http://printer-review.weebly.com Visit

Reply

Name
eMail (not visible)
Subject (no text only in upper case; no HELP, URGENT...)
Text
HTML tags are not supported and links are generated automatically if they start with http or ftp.
Please submit long source code or log files as attachment (only registered users).
Please enter the number: 1 2 5 2