Matrix - Pressure and Temperature Sensor

Fioz
Hi everybody,

I have a NanoPi M3 board with Linux Debian Jessie installed (image
downloaded from friendlyarm links, latest version:

Linux NanoPi3 3.4.39-s5p6818 #4 SMP PREEMPT Wed Nov 16 16:33:05 CET 2016
armv7l GNU/Linux

I'm currently configuring the following Matrix sensors:

- Accelerometer
- Digital Compass
- Pressure and Temperature Sensor

I've been able to connect both accelerometer and digital compass and to
succesfully retrieve values from them but unfortunately I'm experiencing
issues while trying to retrieve data from the Pressure and Temperature
Sensor.

I followed the pinout diagrams of NanoPi M3 and of Pressure and Temperature
Sensors and I'm pretty sure that connections are ok.

Here below is how I connected pins:

SDA   Pin3
SCL   Pin5
5V   Pin4
GND   Pin6 

I tried to get data by using the matrix-pressure_temp command but
unfortunately I received the following errors:

root@NanoPi3:~# matrix-pressure_temp 
Hardware:NANOPI3
Revision:0007
BoardType:68187
FAHW-Lib: Unable to open file
/sys/bus/i2c/drivers/bmp085/unbind/temp0_input
FAHW-Lib: Invalid bmp180 data
Faided to get humidity
FAHW-Lib: Unable to open file
/sys/bus/i2c/drivers/bmp085/unbind/pressure0_input
FAHW-Lib: Invalid bmp180 data
Faided to get pressure
The altitude is 44330.00 m

It seems that the NanoPi is not correctly detecting the sensor (Matrix
APS-01). I also tried to do an i2cdetect -y [0-4] but the sensor is not
detected.

Does somebody of you have any suggestion on how to proceed? Could be the
sensor damaged?

Any help is really appreciated since that sensor is a very important
component of my system.

Thanks a lot!

Best regards,

Marco

davef
Three suggestions:

- have you got just the Matrix temp sensor?  I use DS18B20 on my NanoPi
using the Matrix libs.  Maybe, try that first.  I see that the ones you can
get to work are I2C, so maybe it is a 1wire problem.

- FAHW-Lib: Unable to open file.  I wonder if this refers to libfahw.so 

-  /sys/bus/i2c/drivers/bmp085/unbind/temp0_input and
/sys/bus/i2c/drivers/bmp085/unbind/pressure0_input  Are those files on your
target?

Those other (FAHW-Lib) errors don't seem to be coming from bmp180.c

Reply

Name
eMail (not visible)
Subject (no text only in upper case; no HELP, URGENT...)
Text
HTML tags are not supported and links are generated automatically if they start with http or ftp.
Please submit long source code or log files as attachment (only registered users).
Please enter the number: 3 3 7 7