mini2440 pyxdist acl download problem


I want use my 'old' mini2440 for a new project and I think it's good moment
to update firmware. I use ptxdist for first time. I follow the
I build toolchain OSELAS.Toolchain-2014.12.0 , clean, rm select... -> ok,
no error. 
I run ptxdist (ptxdist-2015.01.0) for roofs, I execute several step before
'go', -> ok
I launch ptxdist go, and I have an error message:
recipe for target
I download this archive and place it in src dir (in the same idea of dl dir
of buildroot) , but I have always the same error.
Could you help me?


Which version of the BSP are you using? 
OSELAS.BSP-Pengutronix-Mini2440-2015.01.0 ?

Is acl something you have enabled in ptxdist menuconfig?

Did it build properly before you started to make changes in menuconfig?

Early on in setting up PTXdist you tell it where the src files are located.

p13 of the latest Quickstart guide and Source Archive Location

   ptxdist setup
      Source directories --->

Hi davef,

big thanks about your speedy answer ;-)
yes for OSELAS.BSP-Pengutronix-Mini2440-2015.01.0 .
I've download/copied again the acl file in src dir, and the ptxdist process
runs correctly 
-- for information --
until the same problem with 'u-boot-2014.07.tar.bz2'. I follow the same
idea, download/copy in src dir. Re-launch 'ptxdist go'. It's ok until
u-boot compilation -> missing openssl/evp.h.
resolved with some 'apt-get install' about openssl (libssl-dev,
libcurl4-openssl-dev, pkg-config)...
New pb with 'dosfstools-3.0.26.tar.xz'...
I keep you in touch!


I don't found dosfstools-3.0.26.tar.xz, just dosfstools-3.0.26.orig.tar.xz.
I take it, rename it ... but I have a md5sum error (normal!) 
I don't know how ptxdist manage md5sum?
an idea?



I found the file! it's OK

finished target world.targetinstall

This step is finished

next step now...
Thanks again

Any files I manually downloaded I never did anything with the md5sum. 
Probably not a professional approach?  I just trusted that the file was not

There is another guide for PTXdist on their website that should tell you
how to do it.  "How to become a PTXdist Guru"

p38 mentions the md5sum


I've done a basic image (without qt, ..) with ext2 fs type->ok
Now I add QT, I2C tools, openssh,... alway in ext2 -> KO
genext2fs: couldn't allocate a block (no free space)
It seems that  is a space problem but I don't find how increase the size of
romfs, for tests.
I'm searching again...
some idea? ;-)

Which kernel version are you using?

What size is the flash on your mini2440?

Beware that adding Qt seemed to create an number of issues.  Every time you
change something involved with Qt it goes through the compete build

Cleaning Qt projects seemed difficult.

I had the /demo/web browser using Qt working but it was not an easy task.

I used Pengutronix for a number of years as there was poor or no mainline
support for the mini2440.  And cross-compiling stuff always seemed to a
difficult process.

There was excellent support for Pengutronix issues.  If using the mini2440
is NOT an "educational" task I suggest moving to something else.  I use the
Nanopi as a mini2440 replacement and life has become so much easier.

Good luck

Hi Davef,

I have do a rootfs with QT, i2ctools, openssh in jfs filesystem, mounted on
an ext2 partition and an 3.16 kernel. It's ok, 
i have a good example of Qt launched at start! It's perfect for my need.
I will see how manage a group of ds18b120, may be with i2c/1-wire bridge.

Thanks for your help!
and thanks for pengutronic/Oselas very good work!

Good work, that didn't take long!

I use a ATmega32U4 dev board running Teensy code for my DS18B120 temp

I am also running the Matrix 1wire code on the NanoPi.  Might be useful to
look at their code.

Ok, I will see the Matrix code, have you a link?

I see 'owfs', but I don' have idea of the portage effort.

I think i'll use the DS2482-800 which is a bridge 1-wire to I2C,  I have to
use others I2C devices, so...


Matrix and then temperature sensor

You seemed to get on top of using the Pengutronix package quite quickly, so
maybe another day or two to sort I2C.  With help I got SPI working with

I'd suggest searching the forum for I2C and see what sort of problems
people had.