Error when compiling Qtopia

Attachment: Error (1.6 KB)
I am getting error during compiling arm-qtopia.
Qtopia version is qtopia-2.2.0-FriendlyARM.Gcc version is 4.4.3
please help me to compiling qtopia successfully. 


Which Linux distro are you using and is the host 32 or 64 bit?

A couple of other thoughts:

- QTopia-2.2.0 was available at the introduction of the mini2440 and the
kernel was  I would verify that you can use 4.4.3 with Qtopia

- do you have to use 2.2.0 and not something later, ie 4.8 ?

A tutorial that might be of interest you will find by Google searching

Attachment: Error_log.txt (1.38 MB)
I am using ubuntu 16.04 LTS,64 bit to build qtopia.
I am using arm-qtopia 2.2.0 and GCC version 4.4.3 that has came in CD with
development kit.I have attached log file of error at time of compiling.
Help me to solve this problem.I have also installed all dependency.


Looked through Error_log.txt searching for <error> and it looks like a
number of things didn't get built.

I know there are problems building stuff on 64 bit machines, for example
from the NanoPi Wiki:

We assume you would use a 32-bit compiler. However if your host runs a
64-bit Linux you need to install some extra packages. For example if your
host runs a Debian 8 Jessie desktop 64 bit system you will need to install
the following packages:

apt-get install build-essential gcc-multilib rpm libstdc++6:i386
libgcc1:i386 zlib1g:i386 libncurses5:i386


I don't know if this applies to your distro.

Good luck!

Attachment: build.txt (11.62 KB)
Now I have tried to compile arm-qtopia using Ubuntu 12.04 LTS,32-bit. I am
getting error in compiling qtopia. I have pult here error message and
attached build log file.

/bin/sh: 1: arm-linux-g++: not found
make[1]: *** [allmoc.cpp] Error 127
make[1]: Leaving directory
*                  ERROR: Building Qtopia has failed.
* Please search the make output for any error messages.

please help me to solve this error.


> /bin/sh: 1: arm-linux-g++: not found

Suggests it can not find the toolchain.

Have you got a path to the toolchain in your /home/.profile or

Try <printenv> on the command line.

I think the tutorial I linked too covers this.

I have check with the printenv command and get below output for PATH.


I have also checked by giving arm-linux-g++ -v command to check toolchain
and got the following output.

Using built-in specs.
Target: arm-none-linux-gnueabi
Configured with:
--build=i386-build_redhat-linux-gnu --host=i386-build_redhat-linux-gnu
--target=arm-none-linux-gnueabi --prefix=/opt/FriendlyARM/toolschain/4.4.3
--enable-languages=c,c++ --disable-multilib --with-arch=armv4t
--with-cpu=arm920t --with-tune=arm920t --with-float=soft
--with-pkgversion=ctng-1.6.1 --disable-sjlj-exceptions
--enable-__cxa_atexit --with-gmp=/opt/FriendlyARM/toolschain/4.4.3
--disable-nls --enable-threads=posix --enable-symvers=gnu --enable-c99
--enable-long-long --enable-target-optspace
Thread model: posix
gcc version 4.4.3 (ctng-1.6.1)

What commands are you running to cross-compile QTopia?

command is : sudo ./build 
configuration of build file is 


cd qtopia-2.2.0-FriendlyARM
echo yes | ./configure -qte '-embedded -no-xft -qconfig qpe -depths 16,32
-system-jpeg -qt-zlib -qt-libpng -gif -no-g++-exceptions -no-qvfb
-xplatform linux-arm-g++ -tslib' -qpe 'edition pda -displaysize 240x320
-fontfamilies "helvetica fixed micro smallsmooth smoothtimes unifont"
-xplatform linux-arm-g++ -luuid' -qt2 '-no-opengl -no-xft' -dqt '-no-xft

make && make install

Try changing last line to:

sudo make

and see if you still get the error.

Then sudo make install (maybe)

See you tomorrow

Thanks but still getting same error for compiling.
Is this error regarding Meta-Object Compiler(moc)? there may be a issue in
allmoc.cpp because of this.

> /bin/sh: 1: arm-linux-g++: not found

I think is the main issue.

Change directory to qtopia-2.2.0-FriendlyARM as in your and then

   arm-linux-g++ - v

Sorry, I see you have a path to arm-linux-g++ in your PATH

But it could be worth checking.

I have run out of ideas.

I have try to build in Ubuntu 64 bit also ans get the following error.

In file included from widgets/qtextbrowser.cpp:46:0:
In instantiation of ‘void QValueStack<T>::push(const T&) [with T =
widgets/qtextbrowser.cpp:238:21:   required from here
error: ‘append’ was not declared in this scope, and no declarations were
found by argument-dependent lookup at the point of instantiation
     void  push( const T& d ) { append(d); }

I don't understand in which library append has included.