nanopi usb ethernet

Dustin
Hello,

I have had the nano for a while and have yet been unable to get up an
running via the quick start guide.

I had trouble with getting the image flashed via fusing but that seems to
be working.

I can see the friendly arm connect via usb but it then resets before a
connection is fully established.

So I have not been able to ssh into the device.

Any clues on why this could be resetting?

I really want to get this thing up and running.
I will likely buy the nano 2 if this works but not sure if I can't get his
up I may look elsewhere.

Please help, ask me any questions that would help you in troubleshooting my
issue.

Dustin
Yay!  I finally got this thing working.

It was my own fault.  I kept trying to modify the fusing.sh because it
seemed to be failing to recognize my sd at /dev/sdb1.  I modified the check
to get it to run and it did, but...

I thought the fusing had been successful but had not installed the linux
image.  I had only got the boot installed.  I was only modifying the check
for fusing in the fusing.sh but the same check is run in the other sh
files.

In the end I went back to the original unmodified fusing.sh and realized my
error was in running from command.

My sd was /dev/sdb1 so I ran ./fusing /dev/sdb1 and this failed every time
with the error "SD reader Unsupported"

Such a simple change but it worked to run ./fusing /dev/sdb

My question is what if I have multiple /dev/sdb? For example /dev/sdb1 and
/dev/sdb2
Is it just the first on that gets chosen?

Also, seems the fusing is setup to accept /dev/sda
Seems risky, why would this be required?

Also,fyi,
I was able to setup an sd card and ssh into the nanopi from Ubuntu 16.04
running in Virtual Box on a Mac.

This is nice because you don't need a devoted or dual boot linux setup and
no worries about any mistakes made.

Anyway, I am excited to finally try it!!

KRISHNENDU J
I have a host computer with ubuntu 16.04. 

I  have booted the nano pi neo AIR board with ubuntu Qt using
windiskimager. 

Now I want to connect it with my computer and do further processing.

 I have done this through ONECOM board. Then I went to the terminal and
executed the command dmesg.


But the USB port cannot find Firendly ARM component but only a pl2303
serial converter.

Could you please help me to solve this program.

Miguel
where is pl2303 prolific driver? i use nano pi 2fire and download linux
headers from https://github.com/friendlyarm/linux-3.4.y

Reply

Name
eMail (not visible)
Subject (no text only in upper case; no HELP, URGENT...)
Text
HTML tags are not supported and links are generated automatically if they start with http or ftp.
Please submit long source code or log files as attachment (only registered users).
Please enter the number: 7 3 6 5