Super vivi Bios menu not showing in DNW

Ayyappan Mk
Hi,

I am using Windows 7 64 bit os. I connected mini2440 to the PC with USB
cable and for serial connection usb to rs232 converter with the supplied
serial cable as I dont have serial port in my PC. I have set the
configuration->Options in DNW as 115200 bps and COM1 and USB download
address as 0x30000000 and clicked connect in the serial port tab of DNW. In
the title bar it showed COM1:115200 and USB:x. With S2 in NOR mode I
switched on the board now USB:OK was shown and there is no yellow
exclamation mark icon in the friendly arm device shown in Device manager.I
flashed supervivi 128MB with the another PC having Windows 7 32 bit OS
having parallel port using H-JTAG flasher. i am using mini2440 with 1GB
Nand flash. My NOR flash is Spansion - s29al016J701f102 and I have selected
flash correctly and after flashing it showed Program and verified
successfully like that.

But i did not get supervivi bios menu. Please help. 

Thanks in advance.

Gautam
Hi Ayyappan,

Does your board show two LEDs as follows:
   1. LED 1 = **ON**

   2. LED3 = **BLINKING**

immediately after power on?

If they are not ON as mentioned above, then you will need to flash
Supervivi-128M again.

Cheers!

Gautam

Ayyappan Mk
Hi Gautam,

in Windows 7 64 bit OS I am not getting the bios menu in dnw
application. Sometimes in the device manager I am getting Unknown Device or
Friendly ARM mini2440/Micro... with yellow exclamation mark icon and
sometimes it is showing in device manager without yellow exclamation mark
icon. Every time before I boot Windows 7 I am disabling driver Signature
Enforcement. Although it is not consistent. So decided to work in Ubuntu
Linux OS.

It seems LED 1 blinking and LED3 ON. My assumption is LED4 is the one that
is closest one to the board's border and LED 1 is the innermost one in the
board.

I am able to see the supervivi bios menu in minicom in Ubuntu Linux 12.04
OS. So decided to work in Linux.

Ayyappan Mk
Can you please suggest any recently working USB download tool for mini2440
in Linux. I am not able to get usbpush. 

Please help.

Regards,
Ayyappan M.

davef
https://github.com/wkoszek/usbpush

If that fails send your email address to:

dave dot festing at gmail dot com

Dave Festing
Attachment: usbpush (21.59 KB)
Try this.

Ayyappan Mk
Hi,

I have only supervivi loaded in Nor flash.No other software is not in my
board. If I have to use this USBPUSH, it was mentioned like I need Uboot
loaded in the board. Can you please suggest any other ways? Or if it is
must to load Uboot, Can I load the Uboot.bin supplied with DVD when the
board was bought by me 5years back? Is it free from issues and will it work
for this uspush?

Thanks,
Ayyappan M.

davef
I am sure I said this recently:

SuperVivi is a "1st stage" bootloader and lives in NOR.

If you really want u-boot ("2nd stage bootloader") then it goes into NAND
using the menu you are presented with in NOR and usbpush.  This will place
u-boot.bin in NAND then u-boot will then be able boot the image.

Please search for <Forrest Bao mini2440> if you want to use u-boot like
this.

Once you have u-boot.bin in NAND you can place your own kernel (uImage) and
root file system in JFFS2 format into NAND.

Ayyappan Mk
Hi davef,

you did not get my question. 
To use USBPUSH do I need uboot already available in the board? 
Now I have only Supervivi in Nor flash and Nand erased cleanly.
How to use usbpush to download images with this stage? 
Can u give link reference for that?

Regards,
Ayyappan M

davef
My understanding is that you need some form of bootloader in NAND.  The
standard FriendlyArm distro has a bootloader in NOR, I thought was called
VIVI and another bootloader in NAND, I thought was called SUPERVIVI.  

The bootloader that goes into NAND has to be able to work with USB, which I
think SUPERVIVI can't.

Forrest Bao's tutorial explains this quite well, I thought.

kalki
hi all
im working with mini2440...arm9 processor,
windows 7 (64bit) and windows xp in vmwarestation
I have set the
configuration->Options in DNW as 115200 bps and COM2 and USB download
address as 0x30000000 and clicked connect in the serial port tab of DNW. In
the title bar it showed COM2:115200 and USB:x. With S2 in NOR mode I
switched on the board now USB:OK was shown and there is no yellow
exclamation mark icon in the friendly arm device shown in Device manager.
actually i can see bootlader menu when using dnw.exe
but problem is that i cant select any command..like if i press"a or d"
nothing happens. 
now what could be the problem ..can someone please help me with this



thanks,
kalki

Reply

Name
eMail (not visible)
Subject (no text only in upper case; no HELP, URGENT...)
Text
HTML tags are not supported and links are generated automatically if they start with http or ftp.
Please submit long source code or log files as attachment (only registered users).
Please enter the number: 5 1 3 0