NanoPi-2 : CPU is over temperature and hang


I've installed the Debian prebuilt image into NanoPi-2.
Bootup Linux login as root user and do nothing, about after 30 minutes the
board will hang, touch the CPU and I see that it is very hot.

What happened to the board ? Did FriendlyARM run the test before release
for production ? Do we need heat sink for the S5P4418 ?

Best Regards

Can you reboot right after a hang and have it running again?

Hot, can you hold your finger on it (<65C)?

Hi Davef,

I think the temperature is over 70 degree, couldn't hold finger longer than
1s, because the chip is very hot. And not able to reboot right after CPU
hang, wait a minutes to let the CPU's temperature slow down, press reset
button and the board is able to boot up again.

NanoPi-2 PCB is small, I think CPU heat sink is not enough, if we run heavy
software, or set CPU speed to 1400000 the board will hang
quickly.Temporally I set CPU speed 800000 to avoid CPU over heat issue.

Best Regards


I asked on their other forum if cpufrequtils was in the kernel.  How did
you set CPU speed?

Mine arrive in a week or two and I will try a small stick-on heatsink.  I
do not need max speed.

Does going down to 800000 (800MHz?) make a big difference?

I had two NanoPC-T1s, one ran hot the other quite cool.  I say "had"
because the hot one finally died.


I've used the following commands to slow down the CPU speed:

echo userspace > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo 800000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq

Available frequencies :

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
1400000 1200000 1000000 800000 700000 600000 500000 400000

Yes, after going down to 800MHz, CPU temperature is lower than before the
board runs normally.

If you have NanoPi2, you can try.

Best Regards


Thank you for the details.  I will make the change when they arrive.

Dave Festing
Attachment: Jan2016b_Hut 021 (Small).jpg (82.95 KB)

The latest Debian image seems to be running at 400MHz and on "interactive"
for the governor.

Attached is a picture of the heatsink that I put on.  The two inductors at
the bottom edge of the heatsink stick up far enough that the heatsink has
to be placed like so.  Also, the adhesive pad contacts the two chips on the
right hand side.

I estimate that on idle it is running maybe 50C.  I am measuring about 2W
going into the 5V power supply, but have not measured the actually DC
current draw.


Here is how to REALLY heatsink the CPU!

What a beautiful job.


Tried your commands, preceded with sudo and I get
: Permission denied

I haven't experienced that little problem before.  Just how did you do it?


I am aware that Debian and Ubuntu handle sudo differently, but the command:

   whoami says root


   sudo whoami comes up with quite a complex list of woes.


   whoami say fa  ?

Is the file /etc/sudoers setup correctly?

Ignore previous post.  After reflashing the Debian image:

   whoami says fa


   sudo whoami says root

Somehow files called sudo and whoami ended up in /etc/sudoers.d in the
non-working rootfs.

Still can't change the CPU frequency.

Hello ,
      Can you do some experiments as my method , I do some change for my
board , and after doing the modify , my board work perfectly . 

    You can modify nanopi2's resistance of R452, which influence of voltage
is VDD_ARM , it's resistace is /100k/1% , but you need to modify the
resistance as  /115k/1% . Hope that I can help you .

My boards came with the new value for R452.  My VDD_ARM_AP is sitting at

Everything else that I have tested works properly.

My only experience echo'ing stuff to /sys/ was on the mini2440 to control
the backlight ... years ago.

There is either something I don't know about accessing files in /sys/ or
/sys/ is not setup so that it works with sudo.

Hi Davef,

Try login with root user & password = fa

Was sorted, see

However, you are correct!

The link doesn't tell you how to do it:

To get to root:


to get back:

   sudo login

Hi Davef,

How have you tried running Linux on NanoPi 2 ? Does the CPU hang like my
board ? I've also tried with Android and encountered the same problem. I'm
very disappointed and intend to use another board.

Oh, I have misread jjm's post above. After changing R452 the board seems to
be better than before.

Thank you very much.


It runs well.  Used a small stick-on heatsink.  Couldn't extract any
information out of Samsung re heatsinking app notes. 

The NanoPC-T2 looks like a good solution :)

Hi Davef,

Thank you very much.

After changing R452 my board runs well too.
NanoPC-T2 seems to be better, I'll purchase one.

Best Regards

i'm using nanopc-t2, have no idea where is R452 is located. can help?

Firstly, the problem was identified on the NanoPi 2.

Secondly, a modification to bootargs was possibly the real solution to the
problem, not changing R452.

Get your NanpPC-T2 up and running, then post any specific problems you

I have the same problem on CPU is over temperature and hang after running
for 1 to 2 hours.

i'm using android, it will restart, sometime it able to boot back but
sometime it will hang on starting.

any post or link for modification on bootargs?

Over-temperature on a NanoPC-T2.  That is a bit disappointing.  I'd hope
the heatsink would have sorted that issue out.

The bootargs modification is to add a rootwait.  Check out the thread(s) on
the new forum.

     Maybe you need add one Pure Aluminum Heat Sink to the