nano does not connect on the internet.

Josť Rubens
I am unable to connect my nanopi the Internet, set up the wifi as teaches
the site, but still is not working wifi.

wlan0     Link encap:Ethernet  HWaddr 04:e6:76:71:52:8e  
          inet addr:192.168.43.10  Bcast:192.168.43.255  Mask:255.255.255.0
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:69 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:13430 (13.1 KiB)

davef
There is a description on their other site:
   friendlyarm.com

Basically:
   turn-wifi-into-ap-mode off

it will tell you to reboot

but it looks like you got this far.


And then maybe:
   systemctl daemon-reload

Then try:
   arp -a
   route -n
   wpa_cli -iwlan0 scan_result 

and post the results.

Josť Rubens
Results:

root@nanopi:~# arp -a
? (192.168.100.207) at 36:86:f5:4c:41:48 [ether] on usb0

root@nanopi:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface
192.168.100.0   0.0.0.0         255.255.255.0   U     0      0        0
usb0


root@nanopi:~# wpa_cli -iwlan0 scan_result 
bssid / frequency / signal level / flags / ssid
00:04:df:8e:05:77  2412  -72 
[WPA-PSK-CCMP+TKIP][WPA2-PSK-CCMP+TKIP][WPS][ESS] JRG1
00:21:91:70:e9:e4  2437  -76  [WEP][ESS]  JRG
1c:af:f7:5a:2a:1a  2417  -89  [WPA-PSK-TKIP][ESS]  Not Found 404

I own two access points here at home, JRG1 and JRG, the configuration I did
was to access the JRG1 point, but I can not. Does the setting is right?
/etc/network/interfaces.d/wlan0

auto lo
iface lo inet loopback
auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-ssid JRG1
wpa-ap-scan 1
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk xxxxxxxx

davef
Re-reading your original post I see that you have an IP address of
192.168.43.10  Where did that come from?

Confirm that you did:

   turn-wifi-into-ap-mode off

And check with:

   cat /sys/module/bcmdhd/parameters/op_mode

Can you get the NanoPi closer to the router you want?  Just during setup
and then see if it still works in the current location.   

Your setup is similar to mine.

Did you manage to SSH into the unit before trying to connect to the
internet?

Josť Rubens
I typed the command cat / sys / module / bcmdhd / parameters / op_mode and
the result is 0 as you can see below:



wlan0     Link encap:Ethernet  HWaddr 04:e6:76:71:52:8e  
          inet6 addr: fe80::6e6:76ff:fe71:528e/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:7110 (6.9 KiB)



root@nanopi:~# cat /sys/module/bcmdhd/parameters/op_mode
0


root@nanopi:~# apt-get update
Err http://wiki.friendlyarm.com jessie InRelease
  
Err http://wiki.friendlyarm.com jessie Release.gpg
  Could not resolve 'wiki.friendlyarm.com'
Err http://ftp.us.debian.org jessie InRelease
  
Err http://ftp.us.debian.org jessie Release.gpg
  Could not resolve 'ftp.us.debian.org'
^Cading package lists... 10%

I am with my nanopi near the router and still is not connecting. Will be
any problem in the configuration?

Josť Rubens
I can connect via ssh on my nanopi without the internet, as the result
below:




jgomes@ubuntu:~$ ssh root@192.168.100.1
root@192.168.100.1's password: 

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Jan  1 12:02:12 2015 from 192.168.100.207

Josť Rubens
Its setting is functioning normally?

davef
After a lot of messing around I finally connected up a UART to serial
converter and watched the boot-up messages.

You will probably see a place where it pauses and counts up to 1 minute 40
seconds then proceed ... that indicates that you didn't connect.

Also, when you do a:

   turn-wifi-into-ap-mode off

you will be told that a systemctl daemon-reload is recommended.

When I did that it finally connected.

I had further struggles every time I changed to a different router.  It
felt like something was not accepting the new router until I messed around
for another length of time.

When it works it seem to keep working, which is helpful :)

davef
> Its setting is functioning normally?

Sorry, don't understand.

davef
Ah, yes I had some issues until I finally followed the tutorial and did a:
   
   apt-get update

Suggest you sort that first.

davef
Do you mean is SSH functioning properly?  Were you able to navigate the
file system?

davef
Check up can ping   http://wiki.friendlyarm.com

Josť Rubens
Were you able to connect to the internet following this site configuration:

http://wiki.friendlyarm.com/wiki/index.php/NanoPi#Setup_Wi-Fi

Josť Rubens
In nanopi file system I can surf, but I can not connect to the Internet by
wifi nanopi. I did the ping and see the result:
root @ nanopi: ~ # ping http://wiki.friendlyarm.com
ping: unknown host http://wiki.friendlyarm.com

davef
Yes, I am able to connect using those parameters.

Got to leave you to it.

Josť Rubens
I thank you for your attention friend, but did all procedure and could not.
Soon I try again.

davef
Sorry, I wasn't paying full attention ... you can't do apt-get upgrade
UNTIL you get connected to the internet.

julio menezes
Jose Rubens,

check /etc/resolv.conf  ( both side )

[]s
julio