NAND flash chip & Pengutronix

I have ordered 5 boards recently and I can't restore the linux + app ".bin"
image I used to program (for more than 50 boards over the 3 last years).

When the change was done from vivi to superboot, I made the SD card to
recover supervivi and that worked for some times. Now I'm doing the same. 

On this 5 new boards, it doesn't work anymore. I can transfer the image but
then nothing happen at boot time (after switching to NAND). Just a single
ascii character on the serial link.

It seems barebox was not starting at all.

Barebox is ok if I load it from RAM (starting with NOR), but then
I can't write it to  NAND.

With one board having still superboot, I was able to load barebox by
placing it on the SD card and using superboot features.

Then, if from this barebox I reload all the kernel and FS using the
(excellent) pengutronix tutorial, I managed to have a running Linux and
application, but have more an more JFFS2 error message like (ECC error)

Does anybody has the truth about all that story ? I've read about nand chip
changed because of EOL, mini2440 being obsolete ...

Also is the new release from pengutronix (2015) able to run on this
probably new NAND chip ?

I'm stuck and spend 20+ hours working on that issue ...

Thanks for any help !

One more thing : Placing the ".bin" file (1Go) on the SDCARD to load it
using superboot doesn't work. I got a "failed" message after bootloader is
loaded successfully. It seems it doesn't even start to load some byte from
the image (path is ok however)

The .bin image was done using DNW and was the one I used many time. Trying
another image doesn't work either.

> probably new NAND chip

What is the part number on your NAND flash chips?

the name is EM63A 165TS-6G from EtronTech.

you maybe right as I have one working which has samsung K4S561632N-LC60 !

However I think (not sure) that I already load my image to an Etrontech
nand when I first met "superboot pre-loaded mini2440" but can't have access
to it to check if it is same part number ...

Is there any solution other than changing to another board ?

Neither of those numbers are mentioned on the downloads page so looks like
things have moved on quite a bit over the past few years.

I am confused by the comment:

   but can't have access to it to check if it is same part number ...

The part numbers are on the top of the chip itself.  Or does Superboot tell
you the part number when you run it?

I meant that I think that it might have already worked a few months ago
with one board having this EtronTech NAND chip in the past (not sure ...),
but now it has been delivered in a product I developed so I have no more
physical access to this board to confirm ...

I am currently compiling the most recent BSP from pengutronix and I'll try
if this happens to work with these chips. Using a more recent kernel could
help. I keep my finger cross !

Oups stupid mistake, this Etrontech chips appears to be the RAM chip, not
the NAND chip !!!

that leaves me even more perplex as the NAND is still a Samsung brand,
"K9K8G08U0B" obviously the same as before.

I doubt if a newer version of that BSP is going to make any difference.

Then there is the whole Superboot versus Vivi issue!

Did you keep an older board for reference?

in /platform-mini2440 there is a logfile, see my comments to very recent

Yes I have one working board for reference, I'll do any test you would
request :-)

I'll have a look at the comment also, thank you.

I would verify that you can still load your images on the reference board. 
Maybe, something has gone wrong with your development setup.

As per to my recent comments: in /platform-mini2440 there is a logfile

Maybe, you should do a diff on the files on your reference board before
trying to change anything!