Ethernet on mini2440

I am trying to use internet on mini2440. But it doesn't respont to ping
command. The terminal just hangs. On booting linux it shows ethernet
connected but is not working. What should i do?

I am using my laptop as hotspot. The ethernet connection works fine when i
connect my laptop with another laptop but doesn't works with mini2440. So i
guess, i need to configure something or am missing something.

I suggest you look at tutorials about configuration of the
/etc/network/interfaces file in your root filesystem.

I read about configuration but my mini2440 has no such directory. So i dont
think that would help. Is there something i missed in kernel compilation or
something else that i should know?

> I read about configuration but my mini2440 has no such directory.

I my experience I would say ... you need one.

Think you had better tell us what you have done, ie which kernel you
complied. Are you using Busybox?

Do you get a command prompt on the target and it is possible to look at
your directory structure from the target?

During the init process typically various files are executed in
/etc/init.d/  to get things running.

I am not aware if you have to tell Busybox to run /etc/network/interfaces
so I would suggest you try dropping a suitably modified example in that
directory.  Try a wired ethernet connection first, ie eth0.  Then look
through the kernel menuconfig options under Busybox and Networking, I

Grab an on-line copy of Building Embedded Linux Systems.pdf

Had to refresh my memory ... ignore 2nd to last paragraph.  I have been
using the Pengutronix BSP for so long now, the process appears to be tied
up with ifconfig and the options in Busybox for the init process.  These
options are NOT done in the kernel, so the question is how are you
preparing your rootfile system?

Buildroot? doing it from scratch?

I downloaded Rootfs-Qtopia-Qt4 from and
used mkyaffs2image-128M tool to get a image of file system.I didnt use
busybox. I needed gpio and spi driver so i only added these 2 drivers while
configuring kernel(used linux- I didnt
change anything else. When i connect LAN cable with ethernet port, a
message pops in command window(PuTTY) indicating that ethernet-link is up
and is working. But i cant use it for even a simple ftp or accessing

> Do you get a command prompt on the target and it is possible to look at
> your directory structure from the target?

Then type busybox (on the target) and you should see a list of utilities
that are enabled.

Then type ifconfig

In the user manual I see:

Linux Application
- busybox1.2.0
- Telnet,Ftp,inetd
- boa(web server)
- madplay
- snapshot
- ishow
- ifconfig,ping,route

Also, I'd be surprised if you can get SPI and/or GPIO working without a
fair bit of messing around.

Have you been following this article?

Yes I can see the directory structure. This is a snapshot of /etc

 I looked for utilities by typing busybox and for a surprise i see there is
no ping command in that. Also if i open internet(in settings) in mini2440
and try to add LAN service. It gives me this error-
"an /etc/pcmcia/network.opts does not exist. please restore this file"

I haven't put my hands on SPI or GPIO yet. All I know is that there is a
directory for them to be used. But before messing with them I would relly
want to use internet on my mini2440.

eth0-settings, what is in there?

Sorry, it has been so long ago that I used the FriendlyArm setup that I may
not be of much further help.

I would wonder why you get that error ... I don't think pcmia has anything
to do with this platform.

Pengutronix just released an update to their mini2440 BSP.  You will get
more help on using that system.

eth0-settings has IP, mask, gateway, DNS and MAC addresses.

Ah, I had lots of trouble trying to communicate directly with the mini2440.
 The physical interface levels on the ethernet would not play ball with my
netbook or desktop.

I had to plug the mini into a hub and the other PC into the hub as well.

Also, you might need the correct ethernet cable, which I believe in a
cross-over cable.  Have you got the cable supplied with the unit?

There should be lots of old threads about this issue.

I find it odd that the user manual says it has ping and it is not there.