Installing Android on NanoPC

icyfire0573
I have been working on the NANO PC T1 recently. When I received it, it was
shipped with the UBUNTU operating system. I have since tried to install the
ANDROID operating system that was provided but it isnít working for me. I
donít know why but when I flash the device it seems to just make it
unbootable. I have booted off of the UBUNTU image on an SD card so that I
could get the device backup and running. I have then tried to flash the
device again to try and make it work with no success. At current, I am
trying to mimic the /UBUNTU_INSTALLINSTALL script to be able to install
android with the files provided from http://pan.baidu.com/s/1bnAH3Dd like
so:

/UBUNTU_INSTALL/eflasher -f -b superboot4412.bin -k Android/zImage -c
"console=ttySAC0,115200n8 androidboot.console=ttySAC0 ctp=2 skipcali=y
vmalloc=512m" -r Android/ramdisk-u.img -s Android/system.img

But that doesnít seem to fix it. 

I have tried to build the most recent version of Android and a kernel but
that doesnít appear to work either. I have found that it looks like it is
possible that the image of android provided is possibly corrupt when
comparing against the more recent image I have compiled:

ANDROID_LOLLY being the android image I compiled and Android being the
provided downloadable file. 

ANDROID_LOLLY/system.img:    Linux rev 1.0 ext4 filesystem data,
UUID=57f8f4bc-abf4-655f-bf67-946fc0f9f25b (extents) (large files)
ANDROID_LOLLY/userdata.img:  Linux rev 1.0 ext4 filesystem data,
UUID=57f8f4bc-abf4-655f-bf67-946fc0f9f25b (extents) (large files)
Android/system.img:          data
Android/userdata.img:        data

Can someone provide me with a different Android source image to download or
some guidance on this?

k.sundeep
Hello icyfire,

Dont try to Work on NANO PC,throw it off and fetch any other board.There is
no single line of support from the officials, and some new pieces are
straight away faulty. I lost 2 boards due to EMMC problem, no idea whom to
contact and where to get it replaced.

Porske
I have the same problem; I also try to flash with MiniTools FriendlyARM and
use different android source, but no booting.
Only xUbuntu work :(