Beginning with FriendlyARM9 2440

Sushil Kumar Prajapati
Hello Everyone,

I am beginner in Embedded System. Recentally, I purchase FriendlyARM9
mini2440 board, and I have more interest in learning Embedded Technology. I
have experience in C programming but no experience in controller
programming.So, please anyone guide me how i go forward in embedded
Technology.. Plzz Help me

davef
Try some of the projects on this site:

http://mini2440vietnam.blogspot.co.nz/

I am sure that it will generate many questions that will advance your
career as an embedded Linux designer :)

Sushil Kumar Prajapati
Hello davef
I am facing little problem, when i connect my ARM9 board to my laptop using
USB to serial converter RS232 serial communication cable. and using minicom
in terminal. they doesn't show any loading in minicom or neither open in
minicom environment.

even i checked all the connectivity with laptop and DB9 


Is there any configuration should i make ?
:(

davef
Yes. What parameters have you set minicom up to?

Are you running Linux or Windows on your mini2440?

Does the mini2440 appear to bootup properly?

Does its terminal window work?

Do you have a /dev/ttySAC0 entry?

Sushil Kumar Prajapati
I am using linux ubuntu 12.04.
Mini2440 does not bootup properly.
Board is working individually. But when i connect with linux in minicom
using serial communication cable. Thay does not show any bootup process. 

I think board RS232 is not working !!!!! 

And i have /dev/ttyUSB0  entry

davef
> What parameters have you set minicom up to?

On the command line:

   minicom -s

davef
Sorry, that should have NOT been /dev/ttySAC0 in my previous post.

Sushil Kumar Prajapati
sudo minicom -s 

> select "serial port setup" then

A -    Serial Device      : /dev/ttyUSB0                              
B - Lockfile Location     : /var/lock                                 
C -   Callin Program      :                                           
D -  Callout Program      :                                           
E -    Bps/Par/Bits       : 115200 8N1                                
F - Hardware Flow Control : No                                        
G - Software Flow Control : No

then 

save setup as dfl

davef
minicom setup looks correct.

> Mini2440 does not bootup properly.
> Board is working individually.

I am a bit confused. Do you mean the mini2440 does work by itself.  In
which case it is booting up

>> Are you running Linux or Windows on your mini2440?

If you are using the board by itself do you get a flashing cursor prompt? 
Can you then perform some basic Linux commands, ie ls   ?

Sushil Kumar Prajapati
I sended the mini2440 board to the company, where i purchased this board.
Let see what they told me .....

I am using Linux Ubuntu 12.04 LTS OS in my Laptop
and I am using Linux on my mini2440 
 
> mini2440 does not bootup properly
   >> means when i connect this board with my laptop using external device
like USB to serial, DB9 connector, serial communication, then they doesn't
show any boot process in minicom environment (in my laptop) when i start
board. 

> Board is working individually
  >> when i am not connect board with any other system. and provide supply
to it then they work properly

davef
With the mini2440 not connected to your host and on the Linux command line:
   cd /dev
   ls tty*

and list all the dev nodes that start with tty*

And just for fun:
uname -a

and tell me what it says.

Sushil Kumar Prajapati
uname -a

Linux sushil-HP-15-Notebook-PC 3.2.0-74-generic #109-Ubuntu SMP Tue Dec 9
16:45:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

davef
Do this on your mini2440 not the host.

Sushil Kumar Prajapati
okk 

Linux FriendlyARM 2.632.2-FriendlyARM #8 Fri Jan 3 19:4:00 CST 2014 armv4tl
unknown

davef
... and 

cd /dev
ls tty*

on the mini2440

ajay kumar
hi im beginner with arm9 mini 2440 .i need gps on windows ce6.0 in arm9 .i
purchesed gps module L80 .i need some help to get gps...

Dheeraj Saxena
Hi,
Im facing problem with mini2440,seems it is not booting properly as it is
not showing any ttyUSB device in /dev.Im using ubuntu 15.4 and  connecting
mini2440 and booting with NOR flash.On power up two green light glow one
continuous glow and one blinks.
Is my board booting correctly with supervivi?
Can I install supervivi using sd card?
Is there way to reinstall supervivi in NOR flash without JTAG?

Thanks,
Dheeraj

davef
> not showing any ttyUSB device in /dev.

Describe how are you connecting the mini2440 to your host.

Have you read recent threads on this issue?

Dheeraj Saxena
Thanks,
I followed link
https://alselectro.wordpress.com/2013/01/06/friendly-arm-mini2440initial...

I connected mini2400 as:
1.power supply
2.Mini2440 serial port connected to laptop USB port using serial to USB
convertor.

Now dmesg showing:
[ 6769.447217] cp210x 2-1.2:1.0: cp210x converter detected
[ 6769.447743] usb 2-1.2: cp210x converter now attached to ttyUSB0

Than I opened putty there I got error
"Unable to connect serial port."
Than I followed following link
http://websistent.com/fix-serial-port-permission-denied-errors-linux/

Follow the steps for permission error but still not connecting.

Than I tried Minicom using serial port connection changed the port to
ttyUSB0 and saved. Than I got the following screen:

Welcome to minicom 2.7
OPTIONS: I18n 
Compiled on Jan  1 2014, 17:13:19.
Port /dev/ttyUSB0, 08:14:16
Press CTRL-A Z for help on special keys 

Now minicom hanges.On removing usb it says:
"cannot connect to device"
on connecting again previous welcome message comes and minicom get hang.


There is a blog related to this possible bug in minicom-
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/244958
They suggested latest kernel but I,m already using latest
4.2.0-34-lowlatency kernel.

What could be the problem?

Thanks.

Dheeraj Saxena
Hi ,
I just able to proceed with minicom getting BIOS prompt:
##### FriendlyARM BIOS 2.0 for 2440 #####
[x] format NAND FLASH for Linux
[v] Download vivi 
[k] Download linux kernel 
[y] Download root_yaffs image 
[a] Absolute User Application
[n] Download Nboot for WinCE 
[l] Download WinCE boot-logo
[w] Download WinCE NK.bin 
[d] Download & Run 
[z] Download zImage into RAM 
[g] Boot linux from RAM 
[f] Format the nand flash 
[b] Boot the system 
[s] Set the boot parameters 
[u] Backup NAND Flash to HOST through USB(upload) 
[r] Restore NAND Flash from HOST through USB 
[q] Goto shell of vivi 
[i] Version: 1138-2K
Enter your selection: 

CTRL-A Z for help | 115200 8N1 | NOR | Minicom 2.7 | VT102 | Offline |
ttyUSB0   

After this it got hanged not able to enter selection from keyboard.It
showing offline|ttyUSB0.So not able to proceed further.

With putty it is still showing message:
"Unable to open serialport:
Unable to configure serial port"

How to resolve these?

Thanks.

Dheeraj Saxena
Minicom problem solved but putty still not working?

pramod
I'm facing the same problem that you have mentioned above. How did you
solve.

minicom -s 
with settings ttyUSB0, 115200, 8N1, Hardware control -NO Software control
-YES
I do not see any logs after starting the board i can see the LCD image
coming up but on minicom.

Please suggest solution.

Thanks.

Ismet
Hello 

I want to now how i can make connection between Mini2440 and my notebook ?
I use windows 7 .

thanks

davef
Putty

Reply

Name
eMail (not visible)
Subject (no text only in upper case; no HELP, URGENT...)
Text
HTML tags are not supported and links are generated automatically if they start with http or ftp.
Please submit long source code or log files as attachment (only registered users).
Please enter the number: 1 8 1 2