Do you need help? Ask me!!!

I have been working with friendlyARM hardware (6410,210, mini210s, mini210,
tiny210 etc) for over two years now. I run a customized version of the
kernel with a custom install image for android. I can help with almost
anything related to getting android running and doing what EVER you want on
these boards. I am a native english speaker (from the USA) and have taken
the time to sift through all the docs in Chinese and or just find the
solution myself. 

If your in need of help let me know. If I give you some helpful info
consider buying me a beer but all advice is free. 

If you have more detailed help needed we can talk.

Good luck to all!

Just curious how you expect this to work?  Do we preface our questions with
"phpn00b"? Which then draws your attention?

I thought the procedure was, if you see a question where you might be able
to help you just reply.

Your first posting on here as well?  And a double post at that.

Hi phpn00b!

First time I see the help offer :)
So, if you'd be so kind, what about the S5PV210 SoC initialization
assembler code?
I have almost all low-level drivers to write non-OS programs, but the
Samsung ROM code inits the interrupts vectors only. I need to
intercept/install routines on PABT/DABT/SWI and do memory relocation.
Sometimes I will dig them by myself, ready solution may speed up this
Thanks anyway!

@anatoly sorry to say but that would be over my head. The use case that I
have for these boards requires a more full OS like Android. I have never
had to go that low level other than rewriting the Samsung UART kernel
driver for a special application that we have the needs a non standard bit

I got it.
My last non standard UART driver was FriendlyARM's 1-wire touchscreen/LCD
interface :)

Dear phpn00b, 
I bought a tiny210 V2 board last year. To my surprise, the UART driver in
WinCe can only receive ASCII codes correctly. If a code over 128 (Extended
ASCII Codes) is sent to the board, the driver send the application layer
messy. Could you please check the problem?

no help, no beer.

Hi phpn00b

Thanks for your reading my question.
I am using FriendlyArm mini210s now.
First: How to custom Android Image?
       I have developed apps for my idea.
       I want to delete unnecessary apps on Android4.0.3 Image.
Second:I want to start my app automatically when power on the device.

Would you like help me about this solutions?
Best regards.

I am using the card fusing tool but when i scan it doesn't see the sd card

When i click scan on The Friendlyarm sd fuser it cant see the sd card. I
tried different cards different PCs different card readers, reformatting,
deep formats even tried Win XP (I know this is not good) but still would
not read.  It shows up on disk management and I can write to it but the
fuser wont read it.

I looked on line but no one else has this problem.
Any ideas 
Thanks guys and girls

Try to launch sdflasher as administrator.

Hi "phpn00b",

I've been trying to configure my H43 LCD on my Nanopc-T1 but I didn't have
a chance for now.

I don't know what specific configuration I need  to write in
FriendlyArm.ini file, my current config is show bellow :

    Action = Install
    OS = Android

    LowFormat = Yes
    VerifyNandWrite = No

    LCD-Type = H43
    LCD-Mode = Yes

    StatusType = Beeper | LED

    ################### Android ####################
    Android-BootLoader = Superboot4412.bin
    Android-Kernel = Android/zImage
    Android-CommandLine = console=ttySAC0,115200n8
androidboot.console=ttySAC0         ctp=2 skipcali=y vmalloc=512m
    Android-RamDisk =Android/ramdisk-u.img
    Android-RootFs-InstallImage = Android/system.img
    Android-UserData = Android/userdata.img

I don't know if I need a LCD Adapter board in order to change the voltage
from 1.8 to 3.3.
The H43 datasheet-manual says that it works with -0.5 to 5V.

The LCD shows a white screen and the touchscreen does not work.

Any suggestions?

Warm Regards


I need to mount the pen drive in Tiny 210, after i inserted the pen drive ,
i clicked on the app "usb storage". It gave out a message as "USB storage
is not mountable". Please let me know how to mount this pen drive.

I also dont know how to SSH to this device, any instructions related to
this would be of great help.


Surya Pradana
I friendlyArm users with Mini2440 series w35, I functioned as an automatic
school bell. when I change the contents of difile '' bell 'after that I
save. I use WinSCP for editing process. but scrips autorun config it does
not want to walk. berlajan remain with the old config. if it needs a
terminal command? if yes, what are his commands? please help me thank you
in advance


I have a nanopc-t1 with ubunto pre installed.
And to activate hdmi on device, I have to use minitool software via my pc
on windonws 7 64 bits.
But when I launch minitool software, it doesn't see the board connected.
I followed the process and the board seems to be in boot mode.
But I suspect the problem come from the detection of the device from the
usb port of my computer.
I tryed this method
But it doesn't work.
Do you have an idea ?

Thank you for your help.

Last info, my computer detect the board as SEC S5PC210 Test B/D

jb soni
Hi phpn00b!

I am working on mini2440 board. I am a collage student and i want to
develop a application in which, i will connect 4 senor on gpio pin.
How can i read digital '0' and '1' over the pins.
In this application i need respond time of 1 msec so i can read the status
of sensor with time resolution of 1 msec. it will increase my accuracy. Can
i achieve using this board.

I need a expert advice and some guidance too. 

Jb Soni

Hello jb soni,
internal 10 bit ADC for sensor or attach new XX bit adc chip

Can  u provide me whole procedure of android porting on mini2440 & its

Hi Everyone, Hope you guys are doing well.

I'm trying to build common_android_kernel-3.10 on mini2440(x35).
Did configuration by merging three configuration (mini2440_defconfig,
android-base.cfg and config_mini2440_x35) files using
scripts/kconfig/ Got zImage successfully, without any

PROBLEM: But the problem is not able to see kernel messages on my pc. I'm
using ttyUSB0 serial cable with minicom tool. Did changes changes on
default kernel command line options as console=ttySAC0,115200. Not able to
find the solution.

I would be thankful if anyone helps me.