NanoPC-T1

Phil_in_China
Just got my NanoPC-T1 seems a nice unit, having some issues with the HDMI
interface, but I am sure it's OK just have to try a different cable maybe.
Connected up via the Android ADT and seems OK.
Anyone else been testing one yet?

Phil

davef
I recall there was similar on the ORDROID U3 platform ... just maybe:

http://forum.odroid.com/viewtopic.php?f=80&t=3323

Phil_in_China
Thanks Dave, ideally I want to run it on my VGA monitor so I got hold of a
HDMI to VGA converter. But it does not work, I will get hold of a different
converter this weekend and try it again.

Phil

Phil_in_China
I am not sure how to fix an "Input signal out of range" that my monitor is
complaining about when running the NanoPC via an HDMI to VGA adapter.
Presumably the monitor cannot achieve the 1080 resolution hence the error
message, but are there any boot options I can change in the NanoPC?

Currently it is set to "LCD-Type = HDMI1080P30" anyone know what options
are available so that I can run with an old monitor?

Phil

davef
I am aware that other similar boards seem to have trouble with 1080.  I can
only suggest searching the RaspberryPi and Ordroid U2 forums for some
clues.

Looks like you have to register:
http://forum.odroid.com/search.php?keywords=vga

The U2 and U3 have a slightly more capable 4412 chip and there were 5 pages
of VGA related postings.

Changhwan Jung
If you use HDMI by linux (not android), friendlyarm's 4412 boards don't
support HDMI output.

I tried to port odroid kernl 3.8 to tiny4412 because of using HDMI port. I
failed why odroid's 4412 board works with secured firmware(I'm not sure.).
I don't have any imformation about secure code. I just confirmed some part
of secure firmware stops tiny4412 on booting linux.

Phil_in_China
********SOLVED********

Finally solved the HDMI problem.
Change the LCD-Type to HDMI720p60 in the FriendlyARM.ini file.
see below

LCD-Type = HDMI720p60
LCD-Mode = No
CheckCRC32=No

However the USB WiFi on the NanoPC-T1 like the Tiny4412 is still not
working, can anyone give an update of when Friendlyarm will get this
working?

Phil

Rusty
I also just received the NanoPC-T1 in hopes of making a XBMC client out of
it. First impressions say that there will be quite a bit of development
work still needed to get Android stable on this board. The connection
through HDMI straight to my TV is working, but I do get the occasional
glitch in the screen. I am also experiencing lag in the mouse cursor along
with lag while playing HD video. I had to purposely set the resolution to
720p to remove a lot of the lag associated with the graphics. There also
seems to be a decent bit of lag over the network (I've streamed HD through
100mbit no problems before but the NanoPC-T1 seems to want to buffer a
lot). 

That, and the unit itself is getting really hot as well. Any help?

davef
Some discussion on another forum pointing out the lack of a heatsink on the
4412 in this product.  I guess I would be verifying that the CPU is the
culprit and see what one could do about heatsinking and/or fan.

A large amount of traffic on that same forum has to do with video related
issues.  Sounds like you are getting similar performance c.f. other similar
product.

Good luck!

Rusty
Dave,

Which forum is that? I am trying to find the most information I can about
this product. I take it I can use the tiny4412 sources? It looks like the
unit was flashed with the tiny4412 android kernel and base system. 

As for getting hot, it might be something to do with the software side of
things. The case they designed for it is open air and this processor is
currently in a phone and tablet or two, no? While a heatsink is a good idea
and I'll be adding one along with a fan when I 3D print my case, but I
don't think the chip itself should be running that hot.

davef
http://forum.odroid.com/index.php

It is 4412 based but the Prime version.  I would expect it to be quite
similar to the 4412 in this product.

> it might be something to do with the software side of
things. 

What, overclocking or different power management setup?  Has their forum
sprung into life?

Rusty
Dave,

At least with a quick browsing of Odroid forums, it looks like they are
having better success with Debian along with Mali drivers/xorg. 

If I can find out how to boot into debian with this unit, I would do it.
Right now I am downloading the tiny4412 DVD, which I hope is in english.

Mindee
Hi,All

We are porting the Odroid software to NanoPC-T1, and going well for now.

P.S, Why not  Odroid use the Linux kernel 3.8 to higher in android? since
it has appeared in Ubuntu 1304 for  Odroid.

And, the samsung Galaxy S3-i9300 has updated to Android 4.3, I guess 
Odroid will do that soon, but still Linux-3.0. 

Mindee

Rusty
Mindee,

That sounds great! 

I'm sure Android will be a fine OS once it is cleaned up and optimized.
I've been running KitKat on my S2 Skyrocket and it's amazing. With extended
battery, I am getting close to 5 days out of it and for being years old
now, it's smooth as butter and can run XBMC just fine (small screen
though). I think that is with a modified 3.0.101 kernel too. 

Another question I have is the heatsink. Do you think I could get away with
running one of those cheap 2 dollar stick on ram heatsinks that are all
over ebay and use a quiet fan mounted a top to draw that heat out? I'm
hoping that will be enough because other components on the board won't
allow a bigger heatsink to fit over everything (height issues).

Mindee
Hi, Rusty

We didn't use heatsink ever, since it's a mobile SOC, and so many mobile
phone use it. I don't think it is necessary to overclock.

Mindee

Phil_in_China
Hi Mindee

Any news when we will be able to use the usb WiFi with Android
on the NanoPC-T1?

Phil

Borg Germany
Hi

Can you help me and answer some questions. How do i get a NanoPC-T1. On
this page http://www.andahammer.com/t1-nanopc/ i can add it to card. After
this i pay it.  But where do i put my address and where are the cost for
shiping to germany?

Borg Germany
found it http://nanopc.org/NanoPC-T1_Feature.html

Mindee
Hi, Phil

We are porting the Odroid software to T1, for now the Ubuntu can run very
well with HDMI output, we'll release a new ROM soon.

for the Android, it will take longer time, anyway, we'll update an Android
rom that can use USB wifi correctly, please wait.

Mindee

Phil_in_China
Thanks Mindee,

Can you post here when you have a new ROM available for the 4412.

Phil

Mindee
Hi,Phil...

we just made a Ubuntu(from Odroid) image for NanoPC-T1/Tiny4412, it is too
big, and need a 8g SD card, please try:

Linux kernel version: 3.8
Ubuntu: Xubuntu 1304

https://www.dropbox.com/sh/thiub5kgcm7tq4g/xDQkYdru8r

Mindee

Phil_in_China
Hi Mindee
The link seems broken.
You can email me phil_in_china at yahoo.com

Thanks


Phil

Mindee
Hi, Phil

Sent, please check

mindee

smile
Hi, Mindee

Is is available to display by HDMI in Xubuntu 1304 ?

Mindee
Hi, smile

It is Xubuntu 1308

Andreas
Hello, I just received mine today, nice board, do you know if there is
support for Linux + Qt for this board, if so where to get the image?

Thanks!

Naveen
I want buy this board in India, where can i get it...?

Rajesh
Hi please give me a proper channel to buy this board in INDIA.

We are waiting for this board.

Please send me details at my email id : embedded.555@gmail.com

fabio
Hi Mindee,

I read that you made an ubuntu image for nanopc. Can I get image please?

And how can I install it?

Thanks

Fabio

Phil_in_China
Hi Mindee

Just installed the latest Android 20140412 (4.2.2) but still no
USB WiFi. 

Any idea when this is going to be fixed on the Tiny4412 and NanoPC


Regards

Phil

NanopcORG
The Android support the USB WiFi, we have test it.
It can support Some USB WiFi , but no all USB WiFi.
I think the USB WiFi you used is not support by the NanoPC Android

Phil_in_China
Could you tell me which one's do work.

Regards

Phil

seware
Mindee,

Will the new Ubuntu image work on the new super4412 boards?

If yes, where can I get the image now? The dropbox link above is dead.

Thank you.

Phil_in_China
NanopcORG or Mindee

Can you tell me which USB WiFi units will work with the NanoPC?
I have four different ones' and none of them will work.

Phil

Hoang_Dinh
USB wifi support RTL8192CU w/ TPLINK WN821N from this website
http://www.arm9.net/nanopc-t1.asp 
@NanopcORG : how to use RPI camera in Nanopc T1? driver

ekrem hacibektasoglu
hi everboy this is include audio spkear out  or soldering pad

James_ind
Hi @ Phil_in_china

Just received the Nano PC T1,I am trying to use HDMI to VGA conveter with
NANO PC T1, but its not working where the converter is perfectly working
with Raspberry pi. So may i know phil which converter u made to work or on
new piece should we do any configuration i.e to load OS etc.
        Please guide me here to start with this board.Thank You

james_ind
Hi Phil

Waiting for your reply....anyone also please suggest the working with
NANOPC T1

kdanley42
How do i backup the eMMC?
I'm using the current Ubuntu image.  I had no problems getting the original
Ubuntu image working, but for some reason, I can't get a backup image from
the eMMC that can boot.  I'm using:

dd if=/{emac} of={usb}/nanopc-ubuntu-v0.0.iso

james_ind
Hi Kdanely,

Can u please send me any tutorial like how to load the UBUNTU into eMMC, i
have recently received the board with ANDROID on it. So please provide any
data to work on this board. Thank you

Phil_in_China
Hi james_ind

I just purchased a HDMI to VGA convertor locally (no name) and it 
seemed to work. Maybe try setting the resolution as low as possible.

Sorry I can't be more helpful.

Phil

sundeep
HI Phil

I have ported Ubuntu 12.04 to NanoPCt1 and using a 11inch HDMI display as
screen, where the display is very small may i know where we will have
friendlyarm.ini file in order change the resolutions, i cant find it in the
SD card images folders.

topkings
Hi All
 i try to flashing system with "Minitools" but have option don't how to do
it. it show "Ram address" "0x          ". It is 8G emmc and 8G sdcard.would
you please help. Thank you.

NoName
Hi All,

I got critical issue with HDMI, where we can find some information about
the FriendlyARM.ini parameters ?

Thank in advance.

Kind regards

NoName

Paul Glenn
I just received my NanoPC-T1 with Ubuntu installed.  It has a 't1' account
pre-installed.  What is the sudo password?

Raimilson
the password is 123456

Alejandra
Hi, Im trying to connect the device NanoPC T1 to a monitor Samsung
syncMaster 2263uw, but the monitor did not show the screen of the ubuntu
system, it showed a message error about the display configuration ("not
optimum mode, recommended mode 1680*1050 60hz"). I tried to do following
things:
1.
following the quickstart manual
http://www.arm9.net/dl/NanoPC-usersmanual-012614II.pdf but in the item  2.2
Flash Mi-Box to Nano PC,  but seemingly the file in the link 
http://pan.baidu.com/s/1jGDiAAa is not available. I  searched the file
tiny4412-tv-images-20140103.7z but it is a corrupted file. I dont know if
this step is fundamental for obtain my screen on the monitor. 
2. 
Im trying to update the android system following this steps
(http://nanopc.org/dev/224.html), but nothing happens. I modified the file
images\FriendlyARM.ini and tried this configuration LCD-Type = HDMI1080P60
or LCD-Type = HDMI720P60 but it doesnt work.
I need your help!!!
thanks.

Awais
@Alejandra 

did you solved the problem with the HDMI. I am facing exactly the same
problem. please guide me.

jiameijiang
You can use the latest zimage to try again. 

http://pan.baidu.com/s/1sj2VyhR