Windows CE 6.0 loading problem in Tiny210v2

Satish babu
I tried to below 4 steps but no use.. 

Step 1. In PC, open the file "images/FriendlyARM.ini" in TF-card and edit
some item as follow:
#This line cannot be removed. by FriendlyARM(
Action = Install
OS = CE6
LCD-Mode = No
LCD-Type = S70
LowFormat = Yes
VerifyNandWrite = No
StatusType = Beeper | LED
################### Windows CE6.0 ####################
WindowsCE6-Bootloader = Superboot210.bin
WindowsCE6-BootLogo = WindowsCE6\bootlogo.bmp
WindowsCE6-InstallImage = WindowsCE6\NK.bin
WindowsCE6-RunImage = WindowsCE6\NK.bin

Step 2. Set the board as SD card boot mode(set S2 for SDBOOT), and insert
the SD card to the board.
Step 3. Power on the board, the buzzer will ring one times.
Step 4. Check the board LED and Buzzer, Buzzer will ring a bit of times,
then it means update the
system success.

I succeeded up to step 3 . After step 3 I waited 15 min but buzzer not
After 15 min I set  S2 to Nand Flash mode and power on the board same
android is booted ( windowsCE 6.0 not loaded) but android touch also not
I tried Action = Run also but same no changes…

SDk board: Tiny210V2
LCD Model : S700
We connected HDMI monitor also.

Please give me your valuable suggestions and resolve my issue.

Did you try OS = WindowsCE6 ?

I tried OS = WindowsCE6

but no use...

not sure what to suggest, I don't have a tiny210v2, however, superboot
should display progress information on the LCD, it should also output
information to con1 (serial port).


I think your problem comes from the way you prepare your SDCard. In fact,
files on your SDCard must be placed in a directory called "Images". You
must create this directory on root:  /images/->and place here all your

You can connect the serial cable on the debug UART and launch any
hyperterminal like software, then, you'll see informations regarding the
installation progress, and, if any problem occurs, then, you'll be inform.

I'm sure your problem comes from the location of your files on the, just try what I told you...

Good Luck !


Satish babu
Thanks leo you are told to me is correct...

i placed files in Image folder..working fine. 

?But i have another problem. When i build a windows ce 6.0 image its
created successfully without errors. and installed in tiny210v2 also good
but after booting completed its shows bootlogo only not windows ce desktop.

friendly arm provided nk.bin was working correctly.. i created one is

Please help me what was i wrong..

I have the same problem too.
For what I know the problems seems due to the image not loaded into RAM.
It's got flashed but not loaded when you switch S2 to NAND

Hi Kuhdav,

Do you have any solution for that? Please tell me.

Hi Satish babu,

I'm happy to see that you've solved your first problem... but now, you seem
to have reached the second step problem : Loading an image that you've
built with Platform Builder.

Unfortunately, I have the same problem... Using the provided nk.bin on the
DVD, it works fine, but if I try to build mine, I see the boot logo on
startup, and when the progressbar is full, nothing happens, I can't access
to the Window desktop...

I think there is something wrong with the used drivers. I'm not a
specialist, but it appears that Mini210 Catalog in Platform Builder is
absolutely not complete... And it's a little bit hard to understand how to
add new drivers to the Catalog, and how to use them in the build (need to
have a Sysgen variable associated, etc...)

Any help would be appreciated.


Hi Friends...

 My side also same issue...I am working this issue form last 10 days but no

Provided 'NK.bin' on the DVD, it works fine, but if I try to build mine, I
see the boot logo on start up, and when the progress bar is full, nothing

Friendlyarm Please resolve this issue ASAP. We are all stuck at this issue.

Thanks & Regards

To Satish and all other mates:

I built a DEBUG image and ran (enabling COM1 for Debug too) so I could see
what happens behind the scenes.

I found out that the image get loaded and NK.BIN starts expanding on NAND
(I have the mini210s with 4G flash) but then stops complaining it doesn't
mount a bootable fylesystem.

So I got back to the platform.reg and cut off all the stuff regarding
Autoload. THen Tried again and the process of expanding NK.BIN go a little
bit further. It seems that the NK.BIN is able to create and format
partitions butbthen stops again getting an exceptiion.

Could it be something in the HIVE registry handling?
Hope that someone can help us because the board is very attractive but at
the moment is completely useless, At least for us (sigh!!!)


Thanks a lot for your feedback on your last investigations.
As you say, this board is very attractive... too bad that it's not as easy
as "Compile with provided BSP and play".

Actually, we are not able to make it work. I think FriendlyARM should post
an information in this forum regarding CE compilation, or release another
BSP pack.

Actually, we cannot say that the board run under WinCE6.0, we are totally
blocked, and we cannot begin to develop our embedded application to run on

We keep in touch if anyone as good news regarding a successfull NK.bin
generated image.


Hi Kudav, Leo and others,

     Do have any clue regarding this issue.


Hi Kudav, Satich, and others,

It works !!!

For me, and after a lot of investigations (and thanks to FriendlyARM
support), I tried something very simple...

My actual PC is under Win7 (64bits), and I have the famous problem while
booting under WinCE6.0, after a successful compilation under platform
builder, with no errors.

So, I took another PC, under Win7 (32 bits), and I have reinstalled all the
developement environment, following the Tiny210 Development manual, line by
line (Fisrt Visual Studio 2005, then, VS2005 service pack 1, then VS2005
update for Vista... etc.)

Then, I have installed WinCE6.0 suite, opened the Win210-en project, and,
without touching to any parameter, Advanced Build -> Sysgen.

After 15 minutes, nk.bin was generated without error, for a size of about

I have uploaded  it on the flash using SD card and superboot,
and.......MAGIC...... it WORKS !

Help this will help you,

Keep in touch,


Thank you Leo

Thought I was not much confident to succeed I downloaded the last rolling
updated for WINCE 6.0 R3 released by Microsoft (dated: 10-31-2012) and 
according with Leo, I got a working NK.BIN 

Now I'm struggling again because since when I included the "Command Shell"
from the catalog I've got another problem: wince takes lot of time to get
loaded and then a console window pops up, showing some errors regarding

Has somebody already encounter the same problem?
Thanks everybody.

Thanks for your info Leo and Kuhdav,

Today I downloaded latest Rolling update
("WinCEPB60-121231-Product-Update-Rollup-Armv4I") but no use..same problem
i stuck at booting time.

How to run a program in kiosk mode in windows ce 6.0

in windows ce 5.0 i add below code in project.reg


Now tell me the procedure for how to run my app in boot time with out open
desktop in wince6.0

It should be right.
Anyway there're at least a couple of alternative:

1) put you program in in the folder: /windows/stup
2) FriendlyArm released an app called Autostart ( if I'm not wrong; I
didn't used it) that allow to specify the program to run at startup.

N.B. put your program in a resident folder (i.e. in the SD card for

Leo & kuhdav provide your email id for future reference..


I got below error...when i build a project on windows ce 6.0


usbdisk6_lib.lib(cd.obj) : fatal error LNK1000: unknown error; consult
documentation for technical support options
NMAKE : fatal error U1077: 'link' : return code '0x3e8'
NMAKE : fatal error U1077: 'C:\WINCE600\sdk\bin\i386\nmake.exe' : return
code '0x2'

Hi Leo

i know its more than a normal request ...but can you add some screen shot
from the first step to the last...i do every single step as mentioned in
this topic..but after i change board to Bootloader..its just a white screen
..then a single BEEP...and then nothing...when i get back to NAND load again...for god sake someone save me..;)

best regards

Roland Tagoe
Pls, a friend gave me a chinese Eben t1 Table, although it was in chinese i
was managing. But later on i lost the entry password and i'm new to tablets
and dont know how to reinstall it. Can you pls help me how i can install a
new WinCE 6.0 or get rid of the password?



It's very simple for loading os image problum occure in mini lap like tiny,
sam, tcl all. first of all flash the nand chip and must put the sd card
after usb way u prepare boot the os ce-6.0 install it , if it is done,
thanks and regards

Bhagavathi Sundar
I tried to Boot Mini6410 with different os like Windows CE, Linux, Ubuntu,
Android i get informations regarding the installation progress  through
hyperterminal but problem is after successful os installation my dispaly
will be white only but hyperterminal works fine. Plz help me to overcome
this problem.