Tiny210 with 7" Capacitive LCD

Phil_in_China
Just got my Tiny210 with the 7" Capacitive LCD, having a problem when
reinstalling android from SD it comes to the touch calibration screen. But
the touch screen does not respond, the options in the boot file
arė:

CheckOneButton=No
Action = Install
OS =Android

LCD-Mode = No
LCD-Type = S70

LowFormat = Yes
VerifyNandWrite = No
CheckCRC32=No

StatusType = Beeper | LED

################### Android 4.0.3 ####################
Android-BootLoader = Superboot210.bin
Android-Kernel = Android/zImage
Android-CommandLine = root=/dev/mtdblock4 console=ttySAC0,115200
init=/linuxrc androidboot.console=ttySAC0 skipcali=yes ctp=1
Android-RootFs-InstallImage = Android/rootfs_android.img

When superboot is running it says the Touch device is 1-wire.

Any help is greatly received.

Phil

Phil_in_China
Solved (by reading the manual)

TheRegnirps
Hey Phil. Are you still in China? (Charlie).

Was it needing S700 for LCD type and Kernel? I have not had to reload one
yet.

Nomad
What was your solution to this? I've checked in the manual but apparently
I'm missing it. I have the same issue you were having with the capacitive
touch and the calibration screen. Let me know. Thank you!

Nomad
All right, I've gotten past the calibration screen by adding this in the
FriendlyArm.ini -- "skipcali=yes" on the line for Android-CommandLine.

Phil_in_China
Hi Charlie

As Nomad said just had to put the "skipcali=yes" in the Android command
line. Should have "RTFM" or "Read The Friendlyarm Manual" !!
Still in China, now working on integrating Z-Wave into the Tiny210.

Phil

TheRegnirps
Cool. Long time no hear. I was in Guangzhou and Shenzhen for a couple weeks
last Spring. I didn't think to try to reach you. 

I have not tried it, but I wonder if LCD-Type=S700 will work? It is the FA
name for that screen.

Dov
Hi,

I am trying to use the 7" capacitive LCD with qt2.2.

I added "skipcali=yes cpt=1" to the Linux init line, but I can't get the
touch screen to work, any advice?

Dov

TheRegnirps
Heard the same thing from someone yesterday. Android supports, working on
the Linux/Qtopia (kernel driver needed no doubt).

Mario Baldini
Hello guys,

When I use skipcali=yes, I can pass the calibration and boot the OS, but
the touch doesn“t work. I already tried with ctp=1 (does it stand for
capacitive touch panel?)

could someone share your FriendlyARM.ini that is working for Tiny210 SKD 1
with Capacitive 7in LCD ?

Thank you

Maik
tiny210V2SDK with 7" screen touch not working:

After trying a lot to get the original android working after a reflash I
found the relevant information inside of the manual. The "ctp=" command
line options selects the touch controller hardware. It looks like there are
different boards with different touch controller out there. Mine came with
FT5304. So instead of using "ctp=1" like in the sample from friendlyarm I
had to use "ctp=3"  (this works for android only, see comment below),:

ctp=0 ==> N/A
ctp=1 ==> 7" touch with GT80X touch controller
ctp=2 ==> 4.3" touch with FT5306 touch controller
ctp=3 ==> 7" touch with FT5406 touch controller

To get the linux images to work you also have to compile/add the correct
kernel module (which is present in the android image only). More details
here: http://www.friendlyarm.net/forum/topic/4678

Maik

Reggie
if you look in the kernel sources, in arch/arm/mach-s5pv210/mini210-lcds.c,
you'll find this:

/* Try to guess LCD panel by kernel command line, or
 * using *W50* as default */

static struct {
  char *name;
  struct s3cfb_lcd *lcd;
  int ctp;
} mini210_lcd_config[] = {
  { "W50",  &wvga_w50,  0 },
  { "A70",  &wvga_a70,  0 },
  { "S70",  &wvga_s70,  1 },
  { "H43",  &wvga_h43,  1 },
  { "A97",  &wvga_a97,  0 },
  { "L80",  &wvga_l80,  0 },
  { "G10",  &wvga_g10,  0 },
  { "A56",  &wvga_a56,  0 },
  { "W101", &wvga_w101, 0 },
  { "W35",  &wvga_w35,  0 },
  { "HDM",  &hdmi_def,  0 },  /* Pls keep it at last */
};

the 3rd value in the struct is used to set ctp and the valid controllers
are as Maik says, if you look in
arch/arm/plat-samsung/include/plat/ctouch.h you will see:

enum {
  CTP_NONE = 0,
  CTP_GT80X,
  CTP_FT5306,
  CTP_FT5406,
  CTP_MAX
};

armdevs.com
More system update details, please see our website, it is the english
version:
http://armdevs.com/doc/fa210/info252.html

NothinRandom
@armdevs.com

Do you what to do if I'm running CE6 with 4.3" capacitive touchscreen on a
mini210s? Mine just doesn't want to cooperate at all! Thanks!

Kevin Lambert
When my tablet with the capacitive toushcreen starts the touch coordinates
are backwards and dont cover the entire screen.  Only the bottom left side
of the screen shows touches and they are displayed towards the middle upper
side (unless I touch the middle upper side then they show up in the bottom
left).  How can I kick off the proper calibration routine for the
capacitive touchscreen?

Reggie
plug a usb mouse or keyboard into the system and run the itest app., then
look for 'recalibrate' in the list and run it.  Now reboot (power cycle)
the mini210s/Tiny210, the recalibrate option will remove a couple of
settings that allow the system to run ts_calibrate when you've rebooted,
before you get the android text on screen.  Once you've successfully
calibrated the screen it will finish up booting android.

Kevin Lambert
That didnt work unfortunately.  The reboot doesnt start the calibration
utility.  Part of the installation instructions specifically for the
capacitive touchscreen is to set skipcali=yes as part of the commandline so
that calibration is skipped.  I wonder if there is a kernel option for the
capacitive touchscreen.

Reggie
coming back to this, I'm not entirely sure how all of the touchscreen stuff
is setup, running ICS, I don't see any ts_calibrate files etc.  I can see
them just fine on android 2.3 and a mini6410, that procedure I mentioned
works, if I remove skipcali on my mini210s, it breaks my kernel with
ts_config errors.

Kevin Lambert
Same here.  I cant boot if skipcali is removed but yet I cant calibrate the
touchscreen without a calibration routine.

Reggie
I've just hacked up my drivers to work in android 4.0.3, not sure if the
same things apply here or not as it's a resistive touch screen, see here
for more details:
http://www.friendlyarm.net/forum/topic/4895

Kevin Lambert
Something very odd just happened.  My contact at friendlyarm had me try
ctp=1 since its also for a 7" tablet but the touchscreen wouldnt respond at
all for that so I put it back to ctp=3 and reflashed and now the
touchscreen is fully working.  I havent done anything differently (same SD
card as before with the same images on it).

Reggie
I guess it depends on which FT touchscreen you have? or is yours goodix? 
If you look at the above mini210_lcd_config[] array, you can see that there
are only 2 screens marked with ctp value being 1?  I wonder if you have to
find your lcd in the list S70,A70? and change the value from 0 to 1 or even
3?

It feels like the code can go off and check those values against the screen
but it's also capable of pulling the ctp info from the cmdline, so I'm not
entirely sure what's going on there.

I do know that ts and lcd drivers all seem to have some kind of loose
inter-dependency due to #defines for picking up the various touchscreens,
which can end up breaking the drivers if you turn the wrong driver off in
the menuconfig.

Marcel
included only one ini file the FriendlyARM on images folder

no files in root diretory

and use  skipcali=yes and correct lcd size ctp

Reggie
try using ctp=2.

Thuo Mwangi
skipcali=yes ctp=2 
worked for me.
Thanks guys

red_face
i used ctp=3 as well as ctp=1 also,my lcd size is 7 inch but my board is
not calibrating , the cross point is not responding..someone plz help

red_face
CheckOneButton=No
Action = Install
OS =Android
when i used the Android-RootFs-InstallImage = Android/rootfs_android.img
the update was un-successfull but when i used Android-RootFs-InstallImage =
Android2.3.1/rootfs_android-mlc2.img the update was successful but the
screen is not responding to calibration


LCD-Mode = No
LCD-Type = S70

LowFormat = Yes
VerifyNandWrite = No
CheckCRC32=No

StatusType = Beeper | LED

################### Android 4.0.3 ####################
Android-BootLoader = Superboot210.bin
Android-Kernel = Android/zImage
Android-CommandLine = root=/dev/mtdblock4 console=ttySAC0,115200
init=/linuxrc androidboot.console=ttySAC0 skipcali=No ctp=3
Android-RootFs-InstallImage = Android/rootfs_android.img

When superboot is running it says the Touch device is 1-wire.


Any help is greatly admired.

red_face
p.s board is mini 210s

Reply

Name
eMail (not visible)
Subject (no text only in upper case; no HELP, URGENT...)
Text
HTML tags are not supported and links are generated automatically if they start with http or ftp.
Please submit long source code or log files as attachment (only registered users).
Please enter the number without blanks: 5 1 1 4