DNW usb not working.

Sumeet Thakre
Hello,

I am trying to load the Wince Images using DNW.

I am connecting my pc and mini6410 board thorgh serial and usb cable.

then I RUN DNW tool.
After connecting to serial port it shows me..

[COM1,115200bps][USB:x][ADDR:0x32000000]

and bios menu.


but if I go to transmit any file using USB it shows me "Can't open USB
device"

what should be the problem?


Please guide me.

Sumeet Thakre
HELLO ALL,

I am still waiting for the Solution of this issue.

Please someone guide me.


THanks in Advance.
Sumeet Thakre.

umer
Hi,
I am facing the same problem  i am using micro2440 sdk board and not able
to connect the board  through DNW 
what is the reason can some body help

umer
Hi,
I am facing the same problem

TheRegnirps
Sumeet, use the 6410's Superboot system. Program from an SD card. There are
detailed directions here somewhere, or I can repeat them.

Umer, you are on a 2440. Are you using the included serial cable? You can
not use a plain serial cable. Plus it can take some fiddling about to get
the correct USB port set on DNW.

Sumeet Thakre
Hello,

Just solved the problem.

The reason was: the driver for mini6410 was not installed in my PC.

I had Installed [usb-downloaddr-setup_20090421]. and then DNW worked fine
and displayed USB:OK.


for more details search for (FriendlyARM
Downloader Instructions)pdf.


Sumeet Thakre.

Sumeet Thakre
Charles Springer ,

Thanks for your valued reply.

yber
Hi,

I have a huge problem with OK6410 board not recognized by usb.

I have intalled that usb_downloaddr (1) but when i plug usb in, it says sec
s3c6410x test b/d. When i try to update firmware using that (2) link when
windows XP detects the hardware it is not working. Even if I choose to
search for the folder where I extracted that package.

So dnw says whole time USB:x, so it's not working. Could someone please
help me get through with this.

(1)
http://www.friendlyarm.net/dl.php?file=usb-downloaddr-setup_20090421.zip


(2) http://www.friendlyarm.net/dl.php?file=usb-downloaddr_20090421.zip

hesam
hello. i gave Sumeet Thakre's solution but is not working.
actually i copied SECBULK.inf file into C:\Windows\inf
and SECBULK.sys into C:\Windows\System32\drivers (is it correct ?)
and it "can't open USB device" yet by dnw.
i have tested on Windows7 32bit with mini6410.
plz help me...
it is very immediate.

hesam
oh, problem fixed...
while the blue cable "and" mini USB cable are connected,
the SD Card must be into mini6410,
and CheckOneButton=Yes in FriendlyARM.ini
now i can monitor everything through dnw

joshil chaudhary
I have formatted NAND flash.
i am using ok6410 ARM11 board and not able
to connect the board  through DNW in SDboot or NOR layout 
what is the reason can some body help me

BaHko
Just to someone that my wonder why his device is not recognized after
installing the USB Drivers.

In order to be recognized you have to switch S2 to NOR and than it will
recognize it.

Procedure

Turn off device (S1 to OFF)
Switch S2 to NOR
Turn on device (S1 to ON)
Connect thru USB B connector
After installing the drivers you can switch back to NAND (S2 to NAND)

jub16
I am using win 7...i got the bootloader and fuse it into my 1gb
pendrive,inserted it into the board...i connected the mini usb cable and
started DNW now i power on the board....i show me
[COM1,115200bps][USB:x][ADDR:0x32000000]..now how com i know the com the
baud..i don't know but i got it...how could i define the usb?........pls
help...i even tried pressing reset and powering the board on.

oztr
jub16,
firstly define your problem clearly in order to get correct answer.
Go to "downloads" section of this website and download manual. Start
reading slowly and you will find all your answers.
Don't panic, read slowly and follow one by one.

janani ramanathan
@BaHko

 i have tried your procedure but unfortunately,the usb driver is still not
recognized and i am currently using win7 32-bit with mini 2440. kindly give
your suggestions.

voiconvuive
@janani, 

you must conduct step by step as following:
1. plug cables ( 2 cables)and not open switch source mini2440

2. play dnw.exe
3. install FriendlyARM_USB-Download-Driver.exe
4. configuration--> option-->11520 and your com number (find in your
computer) --> ok
5. serial port--> connect 
5. now, open source switch kit .
note : if here hasn't menu list NOR Flash, please toogle cable COM to COM
which connect to your kit.

Goodluck

tn88test
I have the same problem. I follow all the steps you provided but there's
still no display of the menu list on DNW.

rutherford
GUys! I am using windows xp professional in vm workstation. Virtual xp
machine is not able to detect my mini 2440 even though i installed USB
driver. Pleas help

kalki
@tn88test

I have the same problem. I follow all the steps provided but there's
still no display of the menu list on DNW.
help me if u already solved the problem

Reply

Name
eMail (not visible)
Subject (no text only in upper case; no HELP, URGENT...)
Text
HTML tags are not supported and links are generated automatically if they start with http or ftp.
Please submit long source code or log files as attachment (only registered users).
Please enter the number: 3 8 7 9