lftp cross-compilation for arm-linux

I've tried to cross compile lftp (lftp.yar.ru) with arm-linux but the
configure command always stops with the message: 

"checking for readline... configure: error: need installed readline-devel

The readline (libreadline 6.2) library is already cross-compiled and placed
on the cross-compiler libraries directory, but the error persists.

Any one knows how to correctly cross compile lftp for arm-linux ?

what's your linux OS?my ubuntu system and like you.i want try redhat.

i use the command
./configure --disable-static --host=arm-linux
and you?

Thank you Slinn, but it didn't change anything...

It seems as the compiler cannot find de readline library, even I've
cross-compiled it and put in the armv4t libs dir.

How can I pass the library location to the cross-compiler?

propaply you need readline library on host installed too?
try installing it with apt-get install libreadline-dev ? or
libreadline6-dev, don't know.

If you want to add a specific library with the configure command i think it
should work with
./configure xxxx -L /path/to/library -I /path/to/include

Thank you antifish

"apt-get install libreadline-dev libreadline6 libreadline6-dev
 Use these commands did not solve the problem.I tried before I answer.

"./configure xxxx -L /path/to/library -I /path/to/include"
I will try this method, it is the way I'm looking for.I have been
associated LIBS and INCLUDE,But the format error.

If failed,I will install fedora.I think have readline-devel for redhat or
(fedora16 released today)2011-11-8

Juergen Beisert
"checking for readline... configure: error: need installed readline-devel
package" is from 'configure', not from the compiler. Give 'configure' the
correct paths to your cross compiled readline headers and libraries.

hai frends,plse help me am very new to this mini2440 .am using linux in
mini2440 kit and am using ubuntu in host development pc.

Nw my target is to compile hello world program in host development pc and
to transfer the binary output in mini2440 kit.

and am able to compile the code in host pc but i dnt knw how to transfer
binary file and to see the results in mini2440

anothr question when i compile the program in development pc in linux
ubuntu."a.out" file is generating.wthr  is it binaryfile.

In mini 2440 which flavour of linux were using ?

pls pls pls help me