please, do someone Know the difference between mkyaffs2image and

Best Regards,

mkyaffs2image is for 64MB Flash and
mkyaffs2image-128M is for 128MB Flash.


If the next board I purchase has 512MB do I need a mkyaffs2image-512MB?
I read, that 1GB boards are already available. 
The question is: do I need a special mkyaffs2image for every flash size?

Best Regards,

The mkyaffs2image-128MB is working for my 1GB NAND as well. I am sure that
mkyaffs2image (without the -128MB extension) only works for NAND <=64MB.

    I was trying to install Embedded Linux 2.6.30 on my 2440 board. But was
unable to do so.

1) I formatted the NAND flash 
2) I transferred u-boot form NOR flash to NAND flash using DNW successfully
3) I burned the linux kernal image (zImage.bin) successfully on the NAND
flash using DNW

 However when i tried installing yaffs ( quotopia ) using DNW , it gave "
Disk space unavailable error "

My NAND flash size is 64MB

Think you will find that u-boot expects to load a uImage.  Search mkimage
and its options.

Most of the tutorials you will find using uboot have this critical line in
their procedure.

I tried..but i get the following error

yaffs: dev is 32505858 name is "mtdblock2"

yaffs: passed flags ""

yaffs: Attempting MTD mount on 31.2, "mtdblock2"

yaffs: block 690 is marked bad

block 691 is bad

yaffs: block 1765 is marked bad

block 1766 is bad

yaffs_read_super: isCheckpointed 0

VFS: Mounted root (yaffs filesystem) on device 31:2.

Freeing init memory: 112K

Failed to execute /linuxrc.  Attempting defaults...

Kernel panic - not syncing: No init found.  Try passing init= option to


[<c0028fd4>] (dump_backtrace+0x0/0x10c) from [<c02a04b8>]

 r7:00000000 r6:c03abee0 r5:c03ab8a0 r4:c0384248

[<c02a04a0>] (dump_stack+0x0/0x1c) from [<c02a0508>] (panic+0x4c/0x124)

[<c02a04bc>] (panic+0x0/0x124) from [<c00244f0>] (init_post+0xec/0x178)

 r3:00000000 r2:c384ad00 r1:c03df000 r0:c032df9c

[<c0024404>] (init_post+0x0/0x178) from [<c000847c>]

 r5:c001d6b0 r4:c001da14

[<c00083b0>] (kernel_init+0x0/0xf4) from [<c0039f30>] (do_exit+0x0/0x620)

 r7:00000000 r6:00000000 r5:00000000 r4:00000000

Think it would help me and others if you say exactly what you are trying to

I wouldn't play around with any other kernel then 2.6.29 or from
the downloads page.  2.6.30 most likely will not have all the patches in
place for the mini2440.

Can you successfully follow the "Mini2440 Downloader Instructions" and get
a working Qtopia?  IE, return the unit to a functioning factory distro.

Then outline what you want to do.

It doesn't look like even the kernel loads properly.  Did you enable it for
a YAFFS2 filesystem?

For some further experience try following the tutorial:
and see what problems you have.

Good luck

I have EM-2440 III board (64 MB NAND Flash) . I wanted to install Embedded
linux 2.6.30 on my ARM board.

I successfully installed u-boot followed by Linux kernel (zImage) and yaffs

But when I reboot the system , i get the error :

" Failed to execute linuxrc "

How do i proceed ?

EM-2440 III is not a FriendlyARM board. Have tried the files that come with
the board (e.g. CD, DVD or download...)?

u-boot can ONLY load uImages
Supervivi can ONLY load zImages

Think you will find that u-boot expects to load a uImage.  Search mkimage
and its options.

Most of the tutorials you will find using uboot have this critical line in
their procedure.

how do i use mkyaffs2image?

I need to shrink my kernels size

mkyaffs2image: image building tool for YAFFS2 built Jul  9 2009
usage: mkyaffs2image dir image_file [convert]
           dir        the directory tree to be converted
           image_file the output file to hold the image
           'convert'  produce a big-endian image from a little-endian

Someone know?

hi everyone,

spaceproblem: also if you have memory space problems than use in supervivi
menu first "q" to get commandline and than "part show", check if you have
necessary space, and you can repartion it, search in forum

mkyaffs2image problem: i solved a problem right know: i cant work with this
image but with linux-root_qtopia-128mb image, but the new problem is, how
can i get a simple kernel withouth qtopia, also how can i modify or create
this image

I need understand what is "-mlc2". What special difference between
mkyaffs2image  and mkyaffs2image-mlc2.
How I can operate under Ubuntu with image created with mkyaffs2image-mlc2?
I ask about methods how such image could be mounted and changed. 
I did not found any descriptions how mount and edit this kind of images.
Is it possible to get source code of mkyaffs2image-mlc2?