Font size is too small in Qt4 app

Hi all

I use Qt creator to write a GUI application for mini2440 (240x320).
I set the font size large in Qt creator, but the text size in mini2440
remain unchanged.
I also try "export QWS_DISPLAY=LinuxFb:mmWidth=52:mmHeight=69" before
running my program, but the result is just the same. Could you help me to
solve it? Thx

Depends of your screen :

You seems to have a W35 screen (like me)

I've put that. If you don't have the transformed option, LinuxFb have to

export QWS_SIZE='320x240'
export QWS_DISPLAY=Transformed:Rot0:mmWidth=69:mmHeight=53

Sorry , do u mean that 
export QWS_DISPLAY=LinuxFb:Transformed:Rot0:mmWidth=69:mmHeight=53 ?

By the way, why width is longer than height in yours? My device's height
should be longer than width.

I have tried this, but in vain.

Should I set a certain font in qt cretor?

Thc a lot

FYI, Here is the script I use

export QWS_DISPLAY=:1
export QWS_SIZE='240x320'
export QWS_DISPLAY=LinuxFb:Transformed:Rot0:mmWidth=69:mmHeight=53

if [ -e $TS_INFO_FILE -a "/bin/grep -q TouchScreen < $TS_INFO_FILE" ]; then
        export QWS_MOUSE_PROTO="Tslib:/dev/input/event0
        if [ ! -s /etc/pointercal ] ; then
                rm /etc/pointercal
        export QWS_MOUSE_PROTO="MouseMan:/dev/input/mice"

export QWS_KEYBOARD=TTY:/dev/tty1

Sorry you don't have a new screen.

Yes on the new W35 screen, the widht is longer than the height.

wifth=320 and height=240.

This are my exports :

export QTDIR=/usr/local/Trolltech/QtEmbedded-4.6.3-arm
export QPEDIR=/usr/local/Trolltech/QtEmbedded-4.6.3-arm
export PATH=$QTDIR/bin:$PATH
export LD_LIBRARY_PATH=$QTDIR/lib:/usr/local/lib:$LD_LIBRARY_PATH
export TSLIB_TSDEVICE=/dev/input/event0
export TSLIB_CONFFILE=/usr/local/etc/ts.conf
export TSLIB_PLUGINDIR=/usr/local/lib/ts
export TSLIB_CALIBFILE=/etc/pointercal
export QT_QWS_FONTDIR=/usr/local/Trolltech/QtEmbedded-4.6.3-arm/lib/fonts
export QWS_MOUSE_PROTO="TSLIB:/dev/input/event0 USB:/dev/input/mice"
export QWS_SIZE='320x240'
export QWS_DISPLAY=Transformed:Rot0:mmWidth=69:mmHeight=53

Check that you have all the font in

Thx, I have changed the font successfully.
But the font size is still unchanged and I am frustrated

Do I need to set any thing in Qt creator?

I just use stylesheet in qt creator to choose font and fontsize like
font: 28pt "WenQuanYi Micro Hei";

And run my program like this

./myprogram -qws -font fontname

I solve it by

export QWS_DISPLAY=LinuxFB:mmWidth=145:mmHeight=85

Just don't know why are 145 and 85...

mmWidth/mmHeight is Physical width and Height  of the screen. Use to
calculate DPI of screen.

solved it by installing package qt4-qtconfig
running qtconfig from console
and set the font size to 23

2nd tab has a sample text preview...

For me I solved it by passing the required frot size during program startup
like: ./myprogram -qws -size 18

For me I solved it by passing the required frot size during program startup
like: ./myprogram -qws -size
actually I find that the value passed after -font doesnt affect the
displayed font it takes the value set by Qt Creator

I found another solution : set the lable font size or any object font size
in css. it becomes true.