Need TCP/IP stack for S3C2440

Any one have developed TCP/IP stack for S3C2440 using Keil compiler or
ADS1.2 by using uIP Library.

hi Lalitha,
           I am also looking for a GRPS stack for SIMCOM module can u
please update me with the information if u find  anywhere and more over can
u plz tell me how u are using that application for using ur TCP/IP stack.

Please Acnkowledge,,

Thanks in advance,

Hi All,

i am trying to make TCP package for mini 2440 but i can't read write from
Non volatile memory(flash).I can't use sd memory card since i am already
using this slot as a interface to enable my SDIO card.

So now i want to know how can i read/write to flash and how to store my bin
file into flash.Is there any chance to use RAM as virtual flash if yes then

Waiting for any help..
thanks in advance.


Hey I came across WhizNets solutions. It seems they have TCP/IP stack for
uip compiled using ADS for S3C2440. For more information go through the

Hi,I have code full TCP/IP stack for my x86 OS, and the way you would need
to start for a no-os dev, is not by trying to implement a full TCP/IP
You need to first get the ethernet to send and receive raw data.
Thats the starting point.

Milan Mladenovic
Attachment: WMR_UCOS-II.RAR (3.25 MB)
I find this on forum.
LwIP inplementation for uCosII on Mini2440

Best Regards 

I am also working on this. To start I am trying to read out the chip ID for
the DM9000. Every time I try to read it after a reset - the first address
reads correctly then the next one reads the same thing. 

ax = dm9000_reg_read(0x0028);
bx = dm9000_reg_read(0x0029);

Uart_Printf("VIDL is %x\n", ax);
Uart_Printf("VIDH is %x\n", bx);

Both Uart outputs will read 46. 

If I read 29 first they both read 0a and ect. I tried various delays to no

Any ideas ?

Continuing along I hit another snag in doing a TCP connection. ARP and Ping
work but I see long delays in Wireshark. I get a "syn" packet and it shows
that I sent the "syn" "ack" packet back 256 milliseconds later. There is no
reason for this delay. It then gets worse. After getting the "ack" followed
by the "psh" "ack" packet (with the HTML GET request) my response shows up
about 3 seconds later - and meanwhile IE resets the connection. Is there a
function in the router or PC that delays a packet with an error but still
sends it through ? Any ideas on what might cause this ?"

I got it to go thru the complete TCP open and close - it looks good in
Wireshark but IE says it can't show the webpage. 

Any ideas ?

Does anybody read this or is this more or less an abandoned forum ?

Activity has dropped a bit over the years, however bare-metal programming a
webserver on this platform is probably not a terribly popular project.

So, it must be a learning experience for you.  I can only suggest that you
have a look at uip from Adam Duckels and maybe my work on getting a
webserver to run on an 8 bit uP found here:

Good luck!

I have it working in IE and Firefox, can deliver the webpage to those
browsers, but not Chrome (does work in IE mode) and not my phone. I believe
it has to do with TCP options. Are their any TCP options that must be
addressed in dealing with Chrome ? Smartphones ?

Works in Chrome - that was the extended window option - but still no phone
operation. I did send the legnth of the SYN packet out the serial port and
it is 76 bytes from the phone so the phone must have a lot of TCP options. 

Anybody know anything about the server requirements for working with a
phone ? TCP options ?