install wlan driver

nattawit
Hello

Now I have wireless adaptor module from your website(VNT6656G).
But when I put iwconfig command on FriendlyARM board, I got "no wireless
attensions" message,and I would like to use wireless adaptor
module(TL-WN620G or TL-WN321) also.

Can you suggest me, 
1.How to enable VNT6656G module on the board.
2.How to insert driver module(TL-WN620G or TL-WN321) to the board.

Thanks,

Nattawit

Lemoner
I have faced similar problem too.
After I have been plugged USB Wifi Module.
It\'s LED edmitted but I still cannot using it.
I\'m not sure I need to do any additional task to configure it.

BR,
Lemoner

Stephan Watterott
Did you install the last linux version?
With the last version it should work.

Lemoner
Dear Stephan,

I have been install latest linux version from file
linux-images-20090609.zip

After that I plugged this module 
http://www.friendlyarm.net/sites/products/wifi.jpg
when using "dmesg" result

usb 1-1: new full speed USB device using s3c2410-ohci and address 2
usb 1-1: New USB device found, idVendor=160a, idProduct=3184
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-1: Product: VNT USB-802.11 Wireless LAN Adapter
usb 1-1: Manufacturer: VIA Networking Technologies, Inc.
usb 1-1: configuration #1 chosen from 1 choice

but it not have wmaster0 and wlan0 to configure
after run iwconfig it show only device below

[root@FriendlyARM /]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

[root@FriendlyARM /]#

Do u have any recommend?

BR,
Lemoner

Clemente
Hello Lemoner,
I have the wifi running using this Qtopia image: [1]

I write down some quick and durty instructions [2] but, I'am sorry, are in
italian, my english is not so good; so please use a online translator [3].

Best Regards.

[1] http://www.friendlyarm.net/dl.php?file=root_qtopia_20090429.tgz
[2] http://code.google.com/p/mini2440-wonderland/wiki/ConfigurazioneWiFi
[3]
http://translate.google.it/translate?u=http%3A%2F%2Fcode.google.com%2Fp%...

Lemoner
Thanks Clemente.

I have tried to use image that you recommended.
When I loaded it via DNW, it completed. But it fail to reboot my Qtopia.

Now I'm loading latest version back again.

I'm not sure which version should work with USB wireless module.

I saw in www.arm9.net (translate from chinese)

http://translate.google.co.th/translate?prev=hp&hl=th&js=n&u...=
 
They said that it support module use Ralink chipset (same as your module).
But my module using VIA chipset VNT6656. I'm not sure this cause problem
ot not.

BR,
Lemoner

Clemente
Lemoner,
the image is working for me. Are you sure that the kernel you are using is
the right one?

Clemente.

Lemoner
Dear Clemente,

I have been followed 
http://www.friendlyarm.net/dl.php?file=linux_download.pdf
when I loading image to Mini2440.

Use your recommend file as image and use supervivi_mini2440 
and zImage_N35 for remaining files.

Do you have any further recommend?
Please feel free to tell me.

Thanks + BR,
Lemoner

clemente
Hello Lemoner,
is now running the qtopia image? If not: did you try the root_qtopia.img
image inside the [1] .RAR file? 

Clemente.

[1] http://www.friendlyarm.net/dl.php?file=linux-images-20090609.rar

Lemoner
Hi Clemente,

Yes, I'm using it too, root_qtopia.img inside linux-image-20090609.rar.
The result was in my 2nd reply on this topic. I does not have wmaster0 
and wlan0 to configure. I can run iwconfig but it not found wlan interface.

[root@FriendlyARM /]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

[root@FriendlyARM /]#

BR,
Lemoner

clemente
> Yes, I'm using it too, 
OK, good! 

> I can run iwconfig but it not found wlan interface.
I think the card is not supported! It's incredible they sell a wifi card
for the mini2440 usage!

Do you search the Internet about the VT6656 chip and linux kernel?
I found this link [1]. Seems that there is a driver that can be compiled.
But does not works well... :-(

Clemente.

[1] https://bugs.launchpad.net/ubuntu/+bug/162671

Stephan Watterott
We have some customers and they use the VT6656 also with the mini2440.
I have contact one and ask him which driver works with the wifi module.
I am now waiting for his response.

clemente
Thank you Stephan,
I'm interested about the VT6656 wifi module too.

Lemoner
Thank you so much Stephan. ^_^

torsten
>We have some customers and they use the VT6656 also with the mini2440.
>I have contact one and ask him which driver works with the wifi module.
>I am now waiting for his response

the via vnt6656 driver does not work with a kernel >= 2.6.29 due to changes
in the kernel. it will not compile.
I had to rewrite the driver (1.19.12) myself to make it work with 2.6.29,
without encryption.

also the driver uses the deprecated linux network stack, wich is not a good
thing. I doubt that via will release a new driver in near future.

anyway the driver should work with 2.6.28.

Lemoner
Dear Torsten,

Thank you for your information.
Now I will wait for new driver from VIA.

How about your rewrite driver? Does it working?

For further I borrowed wireless USB from my friend to test.
It\'s a TP-Link TL-WN321G that Ralink chipset inside.
And it working perfectly. I can browse www via wireless connection.

Thanks all,
Lemoner
Mr.Narongrat Srimee
R&D Engineer
Mobile : +(66)8-9499-8006
E-mail : narongrat@thaieasyelec.com

Venus Supply Co.,Ltd
196/1, Soi Thedsaban-Nimit-Nau 8,
Thedsaban-Nimit-Nau Road, Ladyao,
Chatuchak, Bangkok 10900 Thailand
Tel. +(66)2954-2408 , Fax. +(66)2953-8443
http://www.ThaiEasyElec.com

Boy
I  am  new  for  linux  and  try  put the USB WLAN  of  TP Link WNG312G,
they   are  not  response anything , 
I  like  see  how can  I  config linux 2.6.29 to run thiS USB WLAN  to  use
with ARM9  Friedly board 

Note : when I use  iwconfig, the terminal show 

lo  no  wireless extensions

Thank  you krub

Pankaj
I also got the TP-Link working with WEP. Now I want to configure it for WPA
access but for that I need wpa_supplicant. Is there a pre-built package for
wpa_supplicant available for the 2.6.29 image for mini2440. 

Thanks
Pankaj

Hamdy
please i bought friendlyarm board mini2440 and wifi module VNT6656G but i
don't know how i can install its driver on the board

m.nour
hi,
@Stephan Watterot
did the customer who used the vt6656 with the mini2440 reply or not?
do anyone have the linux driver for the vt6656?
thanks

Girl
someone have the driver for vt6656 module? please

Seniors
Recently we installed WinCe 5.0 on our mini2440 "SAMSUNG S3C2240 ARM9 Board
+7". The issues we are having now is that we can not get the SD card to
open up on the device, neither the touch screen works, we have to connect a
mouse in order to use the screen. If it is possible, can anyone be a
assistance to how to download and run the drivers listed as below.

Drivers -- DM9000, TFT LCD, audio card, touchscreen, SD card, RTC,
expansion serial port, USB camera, USB mouse, keyboard, U-disk.

We will really appreciate if anyone can be a beneficial support to us in
this matter.

Seniors
Recently we installed WinCe 5.0 on our mini2440 "SAMSUNG S3C2240 ARM9 Board
+7". The issues we are having now is that we can not get the SD card to
open up on the device, neither the touch screen works, we have to connect a
mouse in order to use the screen. If it is possible, can anyone be a
assistance to how to download and run the drivers listed as below.

Drivers -- DM9000, TFT LCD, audio card, touchscreen, SD card, RTC,
expansion serial port, USB camera, USB mouse, keyboard, U-disk.

We will really appreciate if anyone can be a beneficial support to us in
this matter.

Screwface
Dear everybody,

I've seen on Andahammer FAQ that Linux kernel 2.6.32.2 should support
VT6656:

Q: Why does FriendlyARM sell a wifi that doesn't work?

A: The RT6656 is fully supported by Windows CE. Most people have not tried
the Windows CE sample included on the DVDs because it is in Chinese. VIA
does not make new drivers for Linux available. They are being worked on.
Use a WN321G (TP-Link, RAlink chip set) or equivalent with Linux. Late
news: The VIA chipset is supported in Linux 2.6.32 and later. 

I tried yesterday, the module is correctly detected whan plugging it, but
iwconfig doesn't report any wlan system.

Did someone manage to get it working?

Vitor Christo
I have the some problem...

Screwface
Hi,

I managed to get the NIC recognized by activating the driver in the kernel
(staging drivers) recompiling the kernel and downloading it on the mini.
Now I have to find time to make wpa-supplicant working and connect the
board to my wifi network.

Regards

Vitor Christo
Dear Screwface, you could provide, please, the new kernel image?

Regards

Screwface
Hi,

I can propose you the original FriendlyARM kernel 2.6.32.2 with T35 screen
and VNT6656 support, is it ok for you?
I'm actually trying to make 2.6.37.3 working but have some troubles to make
it boot properly.

Regards

Vitor Christo
no, not working, I bought the VT6656, because it was being sold on the
site, I believed it worked, but does not work, I give up and buy a TP-LINK.

br0x
Screwface,
can you please share 2.6.32 kernel you mentioned with 6656 support for T35?

Eugênio Burg Filho
Take a look at this...

http://translate.google.com/translate?js=n&prev=_t&hl=en&ie=...

Munawwar
I've now written detailed instructions on how to get this working. (I've
also managed to get WPA2 working). Link -
http://codepasta.com/site/micro/mini2440/wifi-driver.php.

devika
Hi

I am working on mini2440, and using Dlink nano 131 wi-fi module i have
driver compiled for mini2440.

But I am not able establish wi-fi connection i am new to networking can any
one give me how configure for wlan for mini2440...

I guess that mini2240 rootfile system does not come with ready 
configuration for wlan..

davef
No, it doesn't.  So, you have to modify /etc/network/interfaces.

Also, you need wpa_suppliant and set the init process up, ie a
/etc/init.d/startup file that calls wpa_supplicant with the proper
switches.

Which driver did you tick in the kernel?

devika
Dear Davef,

Can you provide me information about what i should include in
/etc/network/interface and for /etc/init.d/startup file...because i tried
to modify eth0 to wlan0 and restarted /etc/init.d/ifconfig-eht0 but system
got hanged...

if i do

iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     unassociated  Nickname:"rtl_wifi"
          Mode:Auto  Access Point: Not-Associated   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
****************************************************************
 iwconfig  wlan0 essid "home"
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; Operation not permitted.

**************************************************************
[root@FriendlyARM /home]# iwconfig  wlan0 mode ad-hoc
[root@FriendlyARM /home]# iwconfig  wlan0
wlan0     unassociated  Nickname:"rtl_wifi"
          Mode:Ad-Hoc  Cell: Not-Associated   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
*******************************************************************

If u see few commands are working and few are not working and when i do 

ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 85:62:9E:AD:78:54
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
********************************************************************
but when i do ifconfig wlan0 up my system gets hanged 


Dave can you give me any suggestion what to do next....also can u provide
me configuration file and setup instructions


looking forward to hear from you
thanks and regards

davef
All my comments are based on my experience with the Pengutronix BSP for
mini2440, Linux kernel 3.7 and the ASUS N10 WiFi dongle.

This is my /etc/wpa_supplicant.conf

******

ctrl_interface=DIR=/var/run/wpa_supplicant
update_config=1
fast_reauth=1

network={
   ssid="TP-LINK"
   scan_ssid=1 
   psk="xxxxxxxxxx"
   proto=WPA2
   key_mgmt=WPA-PSK
   pairwise=CCMP TKIP
   group=CCMP TKIP
   auth_alg=OPEN
}

******

And my /etc/init.d/startup

******

#!/bin/bash

wpa_supplicant -Dwext -i wlan0 -c /etc/wpa_supplicant.conf -B
sleep 30

mount -t vfat /dev/sda1 /mnt/USB_FLASHDRIVE

/home/./data.php &

******

The sleep 30 is to get around an issue with RFkill not being compiled in or
??

Now, your biggest problem is getting wpa_supplicant cross-compiled for your
platform and maybe some other tools (iw and wireless tools).  In the
Pengutronix BSP you just tick the right boxes and it all happens by magic.

Sorry, I don't think this is going to help you a lot unless you go down the
Pengutronix route.

Ah, my /etc/network/interfaces

*******

auto lo
iface lo inet loopback

#auto eth0
#iface eth0 inet static
#address 192.168.1.230
#netmask 255.255.255.0
#broadcast 192.168.1.255
#gateway 192.168.1.1

auto wlan0
iface wlan0 inet static
address 192.168.2.230
netmask 255.255.255.0
broadcast 192.168.2.255
gateway 192.168.2.1

*******

Reply

Name
eMail (not visible)
Subject (no text only in upper case; no HELP, URGENT...)
Text
HTML tags are not supported and links are generated automatically if they start with http or ftp.
Please submit long source code or log files as attachment (only registered users).
Please enter the number: 9 1 7 3